summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocaml-re/ocaml-re-1.3.1.ebuild')
-rw-r--r--dev-ml/ocaml-re/ocaml-re-1.3.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ml/ocaml-re/ocaml-re-1.3.1.ebuild b/dev-ml/ocaml-re/ocaml-re-1.3.1.ebuild
new file mode 100644
index 000000000000..661dd3d7c99e
--- /dev/null
+++ b/dev-ml/ocaml-re/ocaml-re-1.3.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="Regular expression library for OCaml"
+HOMEPAGE="http://github.com/ocaml/ocaml-re"
+SRC_URI="https://github.com/ocaml/ocaml-re/archive/${P}.tar.gz"
+
+LICENSE="LGPL-2-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND=">=dev-lang/ocaml-4.02:="
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit )"
+DOCS=( "CHANGES" "TODO.txt" "README.md" )
+S="${WORKDIR}/${PN}-${P}"