summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocaml-sha/ocaml-sha-1.9.ebuild')
-rw-r--r--dev-ml/ocaml-sha/ocaml-sha-1.9.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/ocaml-sha/ocaml-sha-1.9.ebuild b/dev-ml/ocaml-sha/ocaml-sha-1.9.ebuild
new file mode 100644
index 000000000000..ad4737c153cb
--- /dev/null
+++ b/dev-ml/ocaml-sha/ocaml-sha-1.9.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib vcs-snapshot
+
+DESCRIPTION="A binding for SHA interface code in OCaml"
+HOMEPAGE="http://github.com/vincenthz/ocaml-sha"
+SRC_URI="http://github.com/vincenthz/ocaml-sha/archive/${PN}-v${PV}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt]"
+RDEPEND="${DEPEND}"
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ findlib_src_install
+ dodoc README
+}