summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/parsexp/parsexp-0.14.0.ebuild')
-rw-r--r--dev-ml/parsexp/parsexp-0.14.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ml/parsexp/parsexp-0.14.0.ebuild b/dev-ml/parsexp/parsexp-0.14.0.ebuild
new file mode 100644
index 000000000000..e8c21c548d86
--- /dev/null
+++ b/dev-ml/parsexp/parsexp-0.14.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="S-expression parsing library "
+HOMEPAGE="https://github.com/janestreet/parsexp"
+SRC_URI="https://github.com/janestreet/parsexp/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ dev-ml/sexplib0:=
+ dev-ml/base:=
+"
+DEPEND="${RDEPEND}"