summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ppx_base/ppx_base-0.9.0.ebuild')
-rw-r--r--dev-ml/ppx_base/ppx_base-0.9.0.ebuild13
1 files changed, 3 insertions, 10 deletions
diff --git a/dev-ml/ppx_base/ppx_base-0.9.0.ebuild b/dev-ml/ppx_base/ppx_base-0.9.0.ebuild
index 2a699497cc8c..aac278c71193 100644
--- a/dev-ml/ppx_base/ppx_base-0.9.0.ebuild
+++ b/dev-ml/ppx_base/ppx_base-0.9.0.ebuild
@@ -3,6 +3,8 @@
EAPI=6
+inherit opam
+
DESCRIPTION="Base set of ppx rewriters"
HOMEPAGE="https://github.com/janestreet/ppx_base"
SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
@@ -13,7 +15,6 @@ KEYWORDS="~amd64 ~ppc"
IUSE=""
DEPEND="
- dev-lang/ocaml:=
dev-ml/ppx_compare:=
dev-ml/ppx_driver:=
dev-ml/ppx_enumerate:=
@@ -24,12 +25,4 @@ DEPEND="
dev-ml/ocaml-migrate-parsetree:=
"
RDEPEND="${DEPEND}"
-DEPEND="${DEPEND} dev-ml/opam dev-ml/jbuilder"
-
-src_install() {
- opam-installer -i \
- --prefix="${ED}/usr" \
- --libdir="${D}/$(ocamlc -where)" \
- --docdir="${ED}/usr/share/doc/${PF}" \
- ${PN}.install || die
-}
+DEPEND="${DEPEND} dev-ml/jbuilder"