summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ppx_string/ppx_string-0.14.1.ebuild')
-rw-r--r--dev-ml/ppx_string/ppx_string-0.14.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ml/ppx_string/ppx_string-0.14.1.ebuild b/dev-ml/ppx_string/ppx_string-0.14.1.ebuild
new file mode 100644
index 000000000000..1dba11376c55
--- /dev/null
+++ b/dev-ml/ppx_string/ppx_string-0.14.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Ppx extension for string interpolation"
+HOMEPAGE="https://github.com/janestreet/ppx_string"
+SRC_URI="https://github.com/janestreet/ppx_string/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-ml/base:=
+ dev-ml/stdio:=
+ dev-ml/ppx_base:=
+ dev-ml/ppxlib:=
+ dev-ml/ocaml-migrate-parsetree:=
+ dev-ml/result:=
+"
+RDEPEND="${DEPEND}"