summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/topkg/topkg-0.8.1.ebuild')
-rw-r--r--dev-ml/topkg/topkg-0.8.1.ebuild31
1 files changed, 0 insertions, 31 deletions
diff --git a/dev-ml/topkg/topkg-0.8.1.ebuild b/dev-ml/topkg/topkg-0.8.1.ebuild
deleted file mode 100644
index f5f998058d7e..000000000000
--- a/dev-ml/topkg/topkg-0.8.1.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit findlib
-
-DESCRIPTION="The transitory OCaml software packager"
-HOMEPAGE="http://erratique.ch/software/topkg https://github.com/dbuenzli/topkg"
-SRC_URI="https://github.com/dbuenzli/topkg/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="ISC"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~arm ~ppc"
-IUSE=""
-
-RDEPEND="dev-ml/result:=
- dev-lang/ocaml:="
-DEPEND="${RDEPEND}"
-
-src_compile() {
- ocaml pkg/pkg.ml build --pkg-name ${PN} || die
-}
-
-src_install() {
- # Can't use opam-installer here as it is an opam dep...
- findlib_src_preinst
- local nativelibs="$(echo _build/src/${PN}*.cm{x,xa,xs,ti} _build/src/${PN}.a)"
- ocamlfind install ${PN} _build/pkg/META _build/src/${PN}.mli _build/src/${PN}.cm{a,i} ${nativelibs} || die
- dodoc CHANGES.md DEVEL.md README.md
-}