summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ppx_bench/ppx_bench-0.9.1.ebuild13
1 files changed, 3 insertions, 10 deletions
diff --git a/dev-ml/ppx_bench/ppx_bench-0.9.1.ebuild b/dev-ml/ppx_bench/ppx_bench-0.9.1.ebuild
index 35a254c80821..c17ddf31b27a 100644
--- a/dev-ml/ppx_bench/ppx_bench-0.9.1.ebuild
+++ b/dev-ml/ppx_bench/ppx_bench-0.9.1.ebuild
@@ -3,6 +3,8 @@
EAPI=6
+inherit opam
+
DESCRIPTION="Syntax extension for writing in-line benchmarks in ocaml code"
HOMEPAGE="https://github.com/janestreet/ppx_bench"
SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
@@ -13,7 +15,6 @@ KEYWORDS="~amd64"
IUSE=""
DEPEND="
- dev-lang/ocaml:=
dev-ml/ppx_core:=
dev-ml/ppx_driver:=
dev-ml/ppx_inline_test:=
@@ -22,12 +23,4 @@ DEPEND="
"
RDEPEND="${DEPEND}"
-DEPEND="${DEPEND} dev-ml/opam dev-ml/jbuilder"
-
-src_install() {
- opam-installer -i \
- --prefix="${ED}/usr" \
- --libdir="${D}/$(ocamlc -where)" \
- --docdir="${ED}/usr/share/doc/${PF}" \
- ${PN}.install || die
-}
+DEPEND="${DEPEND} dev-ml/jbuilder"