summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ojquery/ojquery-9999.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/ojquery/ojquery-9999.ebuild b/dev-ml/ojquery/ojquery-9999.ebuild
new file mode 100644
index 000000000000..a4f9a1d20424
--- /dev/null
+++ b/dev-ml/ojquery/ojquery-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit oasis
+
+DESCRIPTION="jQuery Binding for Eliom."
+HOMEPAGE="jQuery Binding for Eliom."
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/ocsigen/ojquery"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/ocsigen/ojquery/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-3"
+SLOT="0/${PV}"
+IUSE=""
+
+RDEPEND="dev-ml/react:=
+ dev-ml/js_of_ocaml:=
+ dev-ml/lwt:="
+DEPEND="${RDEPEND} dev-ml/oasis"
+
+src_prepare() {
+ oasis setup || die
+}