summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Apache-AuthCookie/Apache-AuthCookie-3.270.0.ebuild')
-rw-r--r--dev-perl/Apache-AuthCookie/Apache-AuthCookie-3.270.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-perl/Apache-AuthCookie/Apache-AuthCookie-3.270.0.ebuild b/dev-perl/Apache-AuthCookie/Apache-AuthCookie-3.270.0.ebuild
new file mode 100644
index 000000000000..e318c9457b29
--- /dev/null
+++ b/dev-perl/Apache-AuthCookie/Apache-AuthCookie-3.270.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MSCHOUT
+DIST_VERSION=3.27
+inherit perl-module
+
+DESCRIPTION="Perl Authentication and Authorization via cookies"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=www-apache/mod_perl-2
+ virtual/perl-Carp
+ >=dev-perl/Class-Load-0.30.0
+ virtual/perl-Encode
+ dev-perl/HTTP-Body
+ dev-perl/Hash-MultiValue
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=dev-perl/Apache-Test-1.390.0
+ >=dev-perl/URI-1.310.0
+ >=virtual/perl-Test-Simple-0.940.0
+ !www-apache/mpm_itk
+ )
+"
+src_test() {
+ perl_rm_files t/author-* t/signature.t
+ perl-module_src_test
+}