summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Cache-Simple-TimedExpiry')
-rw-r--r--dev-perl/Cache-Simple-TimedExpiry/Cache-Simple-TimedExpiry-0.270.0-r2.ebuild18
-rw-r--r--dev-perl/Cache-Simple-TimedExpiry/files/Cache-Simple-TimedExpiry-0.27-no-dot-inc.patch21
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-perl/Cache-Simple-TimedExpiry/Cache-Simple-TimedExpiry-0.270.0-r2.ebuild b/dev-perl/Cache-Simple-TimedExpiry/Cache-Simple-TimedExpiry-0.270.0-r2.ebuild
new file mode 100644
index 000000000000..0a7d7fff724f
--- /dev/null
+++ b/dev-perl/Cache-Simple-TimedExpiry/Cache-Simple-TimedExpiry-0.270.0-r2.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=JESSE
+DIST_VERSION=0.27
+inherit perl-module
+
+DESCRIPTION="A lightweight cache with timed expiration"
+# License note: no formal upstream license declaration
+# only an assumed one from 'license => perl' in Makefile.PL
+# Bug: https://bugs.gentoo.org/722854
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+PATCHES=(
+ "${FILESDIR}/${PN}-0.27-no-dot-inc.patch"
+)
diff --git a/dev-perl/Cache-Simple-TimedExpiry/files/Cache-Simple-TimedExpiry-0.27-no-dot-inc.patch b/dev-perl/Cache-Simple-TimedExpiry/files/Cache-Simple-TimedExpiry-0.27-no-dot-inc.patch
new file mode 100644
index 000000000000..ba1d06d93229
--- /dev/null
+++ b/dev-perl/Cache-Simple-TimedExpiry/files/Cache-Simple-TimedExpiry-0.27-no-dot-inc.patch
@@ -0,0 +1,21 @@
+From 5b80a167c8241dd309f7532072deda6c4d8ae6ef Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Thu, 14 May 2020 01:31:25 +1200
+Subject: Include '.' in @INC on Perl 5.26+
+
+---
+ Makefile.PL | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index 2290ec1..53c96c2 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -1,3 +1,4 @@
++use lib '.';
+ use inc::Module::Install;
+
+ name ('Cache-Simple-TimedExpiry');
+--
+2.26.2
+