summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/EV/EV-4.330.0.ebuild')
-rw-r--r--dev-perl/EV/EV-4.330.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/EV/EV-4.330.0.ebuild b/dev-perl/EV/EV-4.330.0.ebuild
new file mode 100644
index 000000000000..4aba09327aae
--- /dev/null
+++ b/dev-perl/EV/EV-4.330.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=MLEHMANN
+DIST_VERSION=4.33
+inherit perl-module
+
+DESCRIPTION="Perl interface to libev, a high performance full-featured event loop"
+LICENSE=" || ( Artistic GPL-1+ ) || ( BSD-2 GPL-2+ )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-perl/common-sense
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ dev-perl/Canary-Stability
+"
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}