summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Net-Patricia/Net-Patricia-1.220.0-r1.ebuild')
-rw-r--r--dev-perl/Net-Patricia/Net-Patricia-1.220.0-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-perl/Net-Patricia/Net-Patricia-1.220.0-r1.ebuild b/dev-perl/Net-Patricia/Net-Patricia-1.220.0-r1.ebuild
new file mode 100644
index 000000000000..b29fdbe2b9e7
--- /dev/null
+++ b/dev-perl/Net-Patricia/Net-Patricia-1.220.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=GRUBER
+DIST_VERSION=1.22
+inherit perl-module toolchain-funcs
+
+DESCRIPTION="Patricia Trie perl module for fast IP address lookups"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="ipv6"
+
+RDEPEND="dev-perl/Net-CIDR-Lite
+ ipv6? (
+ dev-perl/Socket6
+ )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=("${FILESDIR}/${PN}-1.22-no-lnsl.patch")
+src_compile() {
+ emake AR="$(tc-getAR)" OTHERLDFLAGS="${LDFLAGS}"
+}