summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Net-SSH2/Net-SSH2-0.470.0.ebuild')
-rw-r--r--dev-perl/Net-SSH2/Net-SSH2-0.470.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-perl/Net-SSH2/Net-SSH2-0.470.0.ebuild b/dev-perl/Net-SSH2/Net-SSH2-0.470.0.ebuild
new file mode 100644
index 000000000000..da2d6467c822
--- /dev/null
+++ b/dev-perl/Net-SSH2/Net-SSH2-0.470.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=RKITOVER
+MODULE_VERSION=0.47
+inherit perl-module
+
+DESCRIPTION="Net::SSH2 - Support for the SSH 2 protocol via libssh2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gcrypt"
+
+RDEPEND="
+ sys-libs/zlib
+ net-libs/libssh2
+ !gcrypt? (
+ dev-libs/openssl
+ )
+ gcrypt? (
+ dev-libs/libgcrypt:0
+ )
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.50
+"
+
+SRC_TEST="do"
+
+src_configure() {
+ use gcrypt && myconf=gcrypt
+ perl-module_src_configure
+}