summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Net-SSH2/Net-SSH2-0.580.0-r1.ebuild')
-rw-r--r--dev-perl/Net-SSH2/Net-SSH2-0.580.0-r1.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-perl/Net-SSH2/Net-SSH2-0.580.0-r1.ebuild b/dev-perl/Net-SSH2/Net-SSH2-0.580.0-r1.ebuild
index fec5846c8a65..f9768f58738f 100644
--- a/dev-perl/Net-SSH2/Net-SSH2-0.580.0-r1.ebuild
+++ b/dev-perl/Net-SSH2/Net-SSH2-0.580.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -30,6 +30,12 @@ DEPEND="${RDEPEND}
>=virtual/perl-ExtUtils-MakeMaker-6.50
"
+src_prepare() {
+ sed -i -e 's/use inc::Module::Install/use lib q[.]; use inc::Module::Install/' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+ perl-module_src_prepare
+}
+
src_configure() {
use gcrypt && myconf=gcrypt
perl-module_src_configure