summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Pod-Tests/Pod-Tests-1.190.0-r1.ebuild')
-rw-r--r--dev-perl/Pod-Tests/Pod-Tests-1.190.0-r1.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/dev-perl/Pod-Tests/Pod-Tests-1.190.0-r1.ebuild b/dev-perl/Pod-Tests/Pod-Tests-1.190.0-r1.ebuild
index 8b3d49e6f884..ca9f05940b4c 100644
--- a/dev-perl/Pod-Tests/Pod-Tests-1.190.0-r1.ebuild
+++ b/dev-perl/Pod-Tests/Pod-Tests-1.190.0-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-MODULE_AUTHOR=ADAMK
-MODULE_VERSION=1.19
+DIST_AUTHOR=ADAMK
+DIST_VERSION=1.19
inherit perl-module
DESCRIPTION="Extracts embedded tests and code examples from POD"
@@ -16,4 +16,8 @@ IUSE=""
RDEPEND="virtual/perl-File-Spec"
DEPEND="${RDEPEND}"
-SRC_TEST="do"
+src_prepare() {
+ sed -i -e 's/use inc::Module::Install/use lib q[.]; use inc::Module::Install/' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+ perl-module_src_prepare
+}