summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/RadiusPerl/RadiusPerl-0.220.0-r1.ebuild')
-rw-r--r--dev-perl/RadiusPerl/RadiusPerl-0.220.0-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-perl/RadiusPerl/RadiusPerl-0.220.0-r1.ebuild b/dev-perl/RadiusPerl/RadiusPerl-0.220.0-r1.ebuild
new file mode 100644
index 000000000000..5195e6c30ced
--- /dev/null
+++ b/dev-perl/RadiusPerl/RadiusPerl-0.220.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=MANOWAR
+MODULE_VERSION=0.22
+inherit perl-module
+
+DESCRIPTION="Communicate with a Radius server from Perl"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ~sparc x86"
+IUSE=""
+
+DEPEND="
+ >=virtual/perl-Digest-MD5-2.200.0
+ >=virtual/perl-IO-1.12
+ >=dev-perl/Data-HexDump-0.02
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/Authen-Radius-${MODULE_VERSION}
+
+SRC_TEST="do"
+export OPTIMIZE="$CFLAGS"
+PATCHES=( "${FILESDIR}"/dictionary.cisco.ssg.patch )
+
+src_prepare() {
+ sed -i '/install-radius-db.PL/d' Makefile.PL MANIFEST || die
+ mv "${S}"/install-radius-db.PL{,.orig} || die
+
+ perl-module_src_prepare
+}
+
+src_install() {
+ perl-module_src_install
+
+ # Really want to install these radius dictionaries?
+ insinto /etc/raddb
+ doins raddb/dictionary*
+}