summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/libwww-perl')
-rw-r--r--dev-perl/libwww-perl/Manifest1
-rw-r--r--dev-perl/libwww-perl/files/ca-certs.patch30
-rw-r--r--dev-perl/libwww-perl/libwww-perl-6.50.0.ebuild59
-rw-r--r--dev-perl/libwww-perl/metadata.xml34
4 files changed, 124 insertions, 0 deletions
diff --git a/dev-perl/libwww-perl/Manifest b/dev-perl/libwww-perl/Manifest
new file mode 100644
index 000000000000..421777de03ab
--- /dev/null
+++ b/dev-perl/libwww-perl/Manifest
@@ -0,0 +1 @@
+DIST libwww-perl-6.05.tar.gz 132505 SHA256 7b25799ff7eec18e8e4e97dc0cad7b2a5b433b50b13feb59d9179173bee78f23 SHA512 9e9272f72ab28bba1e8c0e85ed21f672e52605b3cc785c9e7d4f930439b75ce9fd43281f6e44c8fd5797404ba82f590de6cd2a6365fa2742fdc8df12a53b9014 WHIRLPOOL 584254383e91dc235b880950227757badb14049a402ac3cc3596ddaf1569a0b733a3f9317b2bd90c54c7e607f90786ed685f0dab28a24122aaad2369518cbcbc
diff --git a/dev-perl/libwww-perl/files/ca-certs.patch b/dev-perl/libwww-perl/files/ca-certs.patch
new file mode 100644
index 000000000000..b0565f0fdba0
--- /dev/null
+++ b/dev-perl/libwww-perl/files/ca-certs.patch
@@ -0,0 +1,30 @@
+X-Bugs-Gentoo: https://bugs.gentoo.org/358081
+--- libwww-perl-6.01/lib/LWP/Protocol/https.pm
++++ libwww-perl-6.01/lib/LWP/Protocol/https.pm
+@@ -21,25 +21,7 @@
+ }
+ if ($ssl_opts{SSL_verify_mode}) {
+ unless (exists $ssl_opts{SSL_ca_file} || exists $ssl_opts{SSL_ca_path}) {
+- eval {
+- require Mozilla::CA;
+- };
+- if ($@) {
+- if ($@ =! /^Can't locate Mozilla\/CA\.pm/) {
+- $@ = <<'EOT';
+-Can't verify SSL peers without knowning which Certificate Authorities to trust
+-
+-This problem can be fixed by either setting the PERL_LWP_SSL_CA_FILE
+-envirionment variable or by installing the Mozilla::CA module.
+-
+-To disable verification of SSL peers set the PERL_LWP_SSL_VERIFY_HOSTNAME
+-envirionment variable to 0. If you do this you can't be sure that you
+-communicate with the expected peer.
+-EOT
+- }
+- die $@;
+- }
+- $ssl_opts{SSL_ca_file} = Mozilla::CA::SSL_ca_file();
++ $ssl_opts{SSL_ca_path} = '/etc/ssl/certs';
+ }
+ }
+ $self->{ssl_opts} = \%ssl_opts;
diff --git a/dev-perl/libwww-perl/libwww-perl-6.50.0.ebuild b/dev-perl/libwww-perl/libwww-perl-6.50.0.ebuild
new file mode 100644
index 000000000000..ecfa4de76faf
--- /dev/null
+++ b/dev-perl/libwww-perl/libwww-perl-6.50.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=GAAS
+MODULE_VERSION=6.05
+inherit perl-module
+
+DESCRIPTION="A collection of Perl Modules for the WWW"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="ssl"
+
+RDEPEND="
+ >=dev-perl/File-Listing-6.0.0
+ >=dev-perl/HTTP-Cookies-6.0.0
+ >=dev-perl/HTTP-Daemon-6.0.0
+ >=dev-perl/HTTP-Date-6.0.0
+ >=dev-perl/HTTP-Negotiate-6.0.0
+ >=dev-perl/HTTP-Message-6.0.0
+ >=dev-perl/LWP-MediaTypes-6.0.0
+ >=dev-perl/Net-HTTP-6.40.0
+ >=dev-perl/WWW-RobotRules-6.0.0
+ >=virtual/perl-Digest-MD5-2.120.0
+ dev-perl/Encode-Locale
+ >=dev-perl/HTML-Parser-3.340.0
+ >=virtual/perl-MIME-Base64-2.120.0
+ virtual/perl-libnet
+ >=dev-perl/URI-1.100.0
+"
+DEPEND="${RDEPEND}"
+PDEPEND="
+ ssl? (
+ dev-perl/LWP-Protocol-https
+ )
+"
+
+src_install() {
+ perl-module_src_install
+
+ # Perform a check to see if the live filesystem is case-INsensitive
+ # or not. If it is, the symlinks GET, POST and in particular HEAD
+ # will collide with e.g. head from coreutils. While under Linux
+ # having a case-INsensitive filesystem is really unusual, most Mac
+ # OS X users are on it, and also Interix users deal with
+ # case-INsensitivity since Windows is underneath.
+
+ # bash should always be there, if we can find it in capitals, we're
+ # on a case-INsensitive filesystem.
+ if [[ ! -f ${EROOT}/BIN/BASH ]] ; then
+ dosym /usr/bin/lwp-request /usr/bin/GET
+ dosym /usr/bin/lwp-request /usr/bin/POST
+ dosym /usr/bin/lwp-request /usr/bin/HEAD
+ fi
+}
+#SRC_TEST=do
diff --git a/dev-perl/libwww-perl/metadata.xml b/dev-perl/libwww-perl/metadata.xml
new file mode 100644
index 000000000000..b7fba106c514
--- /dev/null
+++ b/dev-perl/libwww-perl/metadata.xml
@@ -0,0 +1,34 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">libwww-perl</remote-id>
+ <remote-id type="cpan-module">LWP</remote-id>
+ <remote-id type="cpan-module">LWP::Authen::Basic</remote-id>
+ <remote-id type="cpan-module">LWP::Authen::Digest</remote-id>
+ <remote-id type="cpan-module">LWP::Authen::Ntlm</remote-id>
+ <remote-id type="cpan-module">LWP::ConnCache</remote-id>
+ <remote-id type="cpan-module">LWP::Debug</remote-id>
+ <remote-id type="cpan-module">LWP::DebugFile</remote-id>
+ <remote-id type="cpan-module">LWP::MemberMixin</remote-id>
+ <remote-id type="cpan-module">LWP::Protocol</remote-id>
+ <remote-id type="cpan-module">LWP::Protocol::GHTTP</remote-id>
+ <remote-id type="cpan-module">LWP::Protocol::MyFTP</remote-id>
+ <remote-id type="cpan-module">LWP::Protocol::cpan</remote-id>
+ <remote-id type="cpan-module">LWP::Protocol::data</remote-id>
+ <remote-id type="cpan-module">LWP::Protocol::file</remote-id>
+ <remote-id type="cpan-module">LWP::Protocol::ftp</remote-id>
+ <remote-id type="cpan-module">LWP::Protocol::gopher</remote-id>
+ <remote-id type="cpan-module">LWP::Protocol::http</remote-id>
+ <remote-id type="cpan-module">LWP::Protocol::http::Socket</remote-id>
+ <remote-id type="cpan-module">LWP::Protocol::http::SocketMethods</remote-id>
+ <remote-id type="cpan-module">LWP::Protocol::loopback</remote-id>
+ <remote-id type="cpan-module">LWP::Protocol::mailto</remote-id>
+ <remote-id type="cpan-module">LWP::Protocol::nntp</remote-id>
+ <remote-id type="cpan-module">LWP::Protocol::nogo</remote-id>
+ <remote-id type="cpan-module">LWP::RobotUA</remote-id>
+ <remote-id type="cpan-module">LWP::Simple</remote-id>
+ <remote-id type="cpan-module">LWP::UserAgent</remote-id>
+ </upstream>
+</pkgmetadata>