summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/PEAR-Archive_Tar/PEAR-Archive_Tar-1.3.15.ebuild')
-rw-r--r--dev-php/PEAR-Archive_Tar/PEAR-Archive_Tar-1.3.15.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-php/PEAR-Archive_Tar/PEAR-Archive_Tar-1.3.15.ebuild b/dev-php/PEAR-Archive_Tar/PEAR-Archive_Tar-1.3.15.ebuild
new file mode 100644
index 000000000000..193925722c3f
--- /dev/null
+++ b/dev-php/PEAR-Archive_Tar/PEAR-Archive_Tar-1.3.15.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Tar file management class"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
+IUSE=""
+SRC_URI="http://pear.php.net/get/${MY_P}.tgz"
+DEPEND="dev-lang/php:*[pcre(+)]
+ >=dev-php/PEAR-PEAR-1.8.1
+"
+RDEPEND="dev-lang/php:*[bzip2,posix,zlib]
+ ${DEPEND}"
+PDEPEND="dev-php/pear"
+HOMEPAGE="http://pear.php.net/package/Archive_Tar"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto /usr/share/php/Archive
+ doins Archive/*
+
+ dodoc docs/*
+}