summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/PEAR-HTTP_Request2/PEAR-HTTP_Request2-2.4.2.ebuild')
-rw-r--r--dev-php/PEAR-HTTP_Request2/PEAR-HTTP_Request2-2.4.2.ebuild33
1 files changed, 0 insertions, 33 deletions
diff --git a/dev-php/PEAR-HTTP_Request2/PEAR-HTTP_Request2-2.4.2.ebuild b/dev-php/PEAR-HTTP_Request2/PEAR-HTTP_Request2-2.4.2.ebuild
deleted file mode 100644
index b1f6817200a1..000000000000
--- a/dev-php/PEAR-HTTP_Request2/PEAR-HTTP_Request2-2.4.2.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit php-pear-r2
-
-DESCRIPTION="Provides an easy way to perform HTTP requests"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="+curl +fileinfo +ssl test +zlib"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-lang/php:*[curl?,fileinfo?,ssl?,zlib?]
->=dev-php/PEAR-Net_URL2-2.2.0"
-DEPEND="test? ( ${RDEPEND} dev-php/phpunit )"
-
-src_prepare() {
- sed -i "s~@data_dir@~${EPREFIX}/usr/share/php/data~" HTTP/Request2/CookieJar.php || die
- default
-}
-
-src_test() {
- phpunit tests || die
-}
-
-src_install() {
- php-pear-r2_src_install
- insinto "/usr/share/php/data/${PHP_PEAR_PKG_NAME}"
- doins data/*
-}