summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/PEAR-Net_SMTP')
-rw-r--r--dev-php/PEAR-Net_SMTP/Manifest4
-rw-r--r--dev-php/PEAR-Net_SMTP/PEAR-Net_SMTP-1.10.0.ebuild (renamed from dev-php/PEAR-Net_SMTP/PEAR-Net_SMTP-1.8.1.ebuild)13
-rw-r--r--dev-php/PEAR-Net_SMTP/PEAR-Net_SMTP-1.7.2-r3.ebuild30
-rw-r--r--dev-php/PEAR-Net_SMTP/PEAR-Net_SMTP-1.7.3.ebuild30
-rw-r--r--dev-php/PEAR-Net_SMTP/metadata.xml8
5 files changed, 16 insertions, 69 deletions
diff --git a/dev-php/PEAR-Net_SMTP/Manifest b/dev-php/PEAR-Net_SMTP/Manifest
index 19a6d07c2d8a..addb182d3212 100644
--- a/dev-php/PEAR-Net_SMTP/Manifest
+++ b/dev-php/PEAR-Net_SMTP/Manifest
@@ -1,3 +1 @@
-DIST Net_SMTP-1.7.2.tgz 14795 BLAKE2B e7be5c595e5eb9cd98c0cb82899545b02399ce3aedd35e419a451ad1aa3f4c3c36a10c212508795bc39a044c99206db5ad700f6e7c110eec3b68cb623af4e457 SHA512 06ab00a033709c5f4adc01fabe100ee0033b07e1c5633f995a672bf463484622a5bd976ada9932ee741ff593d739bd1172566f0a8446060bbccde71ea5b0160d
-DIST Net_SMTP-1.7.3.tgz 14855 BLAKE2B b6891196a6871adc3936c89507e3aef1f7d9af045acab09aba5f145a9d1e1da5cee2608873f7a42ebc1d00f99ec733823afe94e15c283245ed1bc035858d94a7 SHA512 b1c2be95c50151e91c2dcc7b9d98233504cc2389c01e4e42e752cba606355da616e570ca86042b68498aad63aaad14ea048b0a0e4e2baa802dc58c440eb60f15
-DIST Net_SMTP-1.8.1.tgz 14931 BLAKE2B 9194e46d1987e48f58c3b851bf6921b4308d39d17b7ca028a4a58a6583171dbe31020477cd7f808ac72ffae81f315e3b416cd5f52e898e0d12cc802af5dbcaa7 SHA512 ba3b68e35d95cc41ef33105402348a322e54c6335d819d1a6e1264f25bc30def4485d0da34901ca203ccd591aeddffbe75b5acb11fb7415a1a13668198aa9942
+DIST Net_SMTP-1.10.0.tgz 15350 BLAKE2B 9603188e5e70aac98135a7ab0248ccff2ebc1cbc2757ce65870228217936acd34249385bea352a3c5f64637ed82621fa17ee717f76d23c586140884d670dcff7 SHA512 4a742ea4521d6ee4889db365691cb3cd8299b9946618e7a80a10d025c4c3f68a91274829fc48ed9d095632e282b32b6e5fede633a5d48e2d995ce48b3893b218
diff --git a/dev-php/PEAR-Net_SMTP/PEAR-Net_SMTP-1.8.1.ebuild b/dev-php/PEAR-Net_SMTP/PEAR-Net_SMTP-1.10.0.ebuild
index bbce75d23463..5667753d0d7d 100644
--- a/dev-php/PEAR-Net_SMTP/PEAR-Net_SMTP-1.8.1.ebuild
+++ b/dev-php/PEAR-Net_SMTP/PEAR-Net_SMTP-1.10.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,18 +12,23 @@ DESCRIPTION="A PHP implementation of the SMTP protocol"
HOMEPAGE="https://pear.php.net/package/Net_SMTP"
LICENSE="BSD-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="examples sasl"
+KEYWORDS="amd64 arm ~hppa ppc ppc64 ~s390 sparc x86"
+IUSE="examples sasl test"
DEPEND=""
RDEPEND="dev-lang/php:*
dev-php/PEAR-Net_Socket
dev-php/PEAR-PEAR
sasl? ( dev-php/PEAR-Auth_SASL )"
+BDEPEND="test? ( ${RDEPEND} )"
+RESTRICT="!test? ( test )"
S="${WORKDIR}/${MY_P}"
src_install() {
- DOCS=( docs/guide.txt )
use examples && HTML_DOCS=( examples )
php-pear-r2_src_install
}
+
+src_test() {
+ pear run-tests tests || die
+}
diff --git a/dev-php/PEAR-Net_SMTP/PEAR-Net_SMTP-1.7.2-r3.ebuild b/dev-php/PEAR-Net_SMTP/PEAR-Net_SMTP-1.7.2-r3.ebuild
deleted file mode 100644
index 515e221db171..000000000000
--- a/dev-php/PEAR-Net_SMTP/PEAR-Net_SMTP-1.7.2-r3.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-MY_PN="${PN/PEAR-/}"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A PHP implementation of the SMTP protocol"
-HOMEPAGE="https://pear.php.net/package/${MY_PN}"
-SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
-LICENSE="PHP-3.01"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
-IUSE="examples sasl"
-DEPEND=""
-RDEPEND="dev-lang/php:*
- dev-php/PEAR-Net_Socket
- dev-php/PEAR-PEAR
- sasl? ( dev-php/PEAR-Auth_SASL )"
-
-S="${WORKDIR}/${MY_P}"
-
-src_install() {
- dodoc docs/guide.txt
- use examples && dodoc -r examples
-
- insinto /usr/share/php
- doins -r Net
-}
diff --git a/dev-php/PEAR-Net_SMTP/PEAR-Net_SMTP-1.7.3.ebuild b/dev-php/PEAR-Net_SMTP/PEAR-Net_SMTP-1.7.3.ebuild
deleted file mode 100644
index 65b32a4c7a3c..000000000000
--- a/dev-php/PEAR-Net_SMTP/PEAR-Net_SMTP-1.7.3.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-MY_PN="${PN/PEAR-/}"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A PHP implementation of the SMTP protocol"
-HOMEPAGE="https://pear.php.net/package/${MY_PN}"
-SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
-LICENSE="PHP-3.01"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="examples sasl"
-DEPEND=""
-RDEPEND="dev-lang/php:*
- dev-php/PEAR-Net_Socket
- dev-php/PEAR-PEAR
- sasl? ( dev-php/PEAR-Auth_SASL )"
-
-S="${WORKDIR}/${MY_P}"
-
-src_install() {
- dodoc docs/guide.txt
- use examples && dodoc -r examples
-
- insinto /usr/share/php
- doins -r Net
-}
diff --git a/dev-php/PEAR-Net_SMTP/metadata.xml b/dev-php/PEAR-Net_SMTP/metadata.xml
index 698c67cb7239..8c8d10200a65 100644
--- a/dev-php/PEAR-Net_SMTP/metadata.xml
+++ b/dev-php/PEAR-Net_SMTP/metadata.xml
@@ -1,10 +1,14 @@
-<?xml version='1.0' encoding='UTF-8'?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>php-bugs@gentoo.org</email>
<name>PHP</name>
</maintainer>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ <name>Michael Orlitzky</name>
+ </maintainer>
<upstream>
<remote-id type="github">pear/Net_SMTP</remote-id>
<remote-id type="pear">Net_SMTP</remote-id>