summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/PEAR-Structures_Graph')
-rw-r--r--dev-php/PEAR-Structures_Graph/Manifest1
-rw-r--r--dev-php/PEAR-Structures_Graph/PEAR-Structures_Graph-1.0.4-r2.ebuild34
-rw-r--r--dev-php/PEAR-Structures_Graph/PEAR-Structures_Graph-1.0.4.ebuild33
-rw-r--r--dev-php/PEAR-Structures_Graph/metadata.xml5
4 files changed, 73 insertions, 0 deletions
diff --git a/dev-php/PEAR-Structures_Graph/Manifest b/dev-php/PEAR-Structures_Graph/Manifest
new file mode 100644
index 000000000000..e7a4685efb04
--- /dev/null
+++ b/dev-php/PEAR-Structures_Graph/Manifest
@@ -0,0 +1 @@
+DIST Structures_Graph-1.0.4.tgz 30318 SHA256 3619ac17892855117283e3555b1a156df0eb4d175e70e63d9c6d27d2c31a2e4f SHA512 40d45c932c571e38807fbfdcf1df6d4fcab29ab43f518ed313bac2bd35a55396aa2b87790dc827bd2e9e5c5f721df55eadfe83ff1a106bf325c467e44556c9fe WHIRLPOOL af2df6bc3d23eae990fa9c258c6277ee35fec8c9efb3e737f84278e5a3ba1d41202c66f8ae69cfc8054fb5f6b544b6407300cf25fe5ba32f4c3975c44f160c91
diff --git a/dev-php/PEAR-Structures_Graph/PEAR-Structures_Graph-1.0.4-r2.ebuild b/dev-php/PEAR-Structures_Graph/PEAR-Structures_Graph-1.0.4-r2.ebuild
new file mode 100644
index 000000000000..eabc826e9662
--- /dev/null
+++ b/dev-php/PEAR-Structures_Graph/PEAR-Structures_Graph-1.0.4-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# BIG FAT WARNING!
+# Do not use any pear eclass here since pear itself depends on this package.
+# Using the pear eclass will thus create a circular dependency
+
+EAPI="5"
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Graph datastructure manipulation library"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+SRC_URI="http://pear.php.net/get/${MY_P}.tgz"
+DEPEND="dev-lang/php:*[pcre(+)]
+ >=dev-php/PEAR-PEAR-1.8.1"
+RDEPEND="${DEPEND}"
+PDEPEND="dev-php/pear"
+HOMEPAGE="http://pear.php.net/package/Structures_Graph"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto /usr/share/php
+ doins -r Structures
+
+ dohtml -r docs/html/*
+}
diff --git a/dev-php/PEAR-Structures_Graph/PEAR-Structures_Graph-1.0.4.ebuild b/dev-php/PEAR-Structures_Graph/PEAR-Structures_Graph-1.0.4.ebuild
new file mode 100644
index 000000000000..58101dec70d7
--- /dev/null
+++ b/dev-php/PEAR-Structures_Graph/PEAR-Structures_Graph-1.0.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# BIG FAT WARNING!
+# Do not use any pear eclass here since pear itself depends on this package.
+# Using the pear eclass will thus create a circular dependency
+
+EAPI="2"
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Graph datastructure manipulation library"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
+IUSE=""
+SRC_URI="http://pear.php.net/get/${MY_P}.tgz"
+DEPEND="|| ( <dev-lang/php-5.3[pcre] >=dev-lang/php-5.3 )
+ >=dev-php/PEAR-PEAR-1.8.1"
+PDEPEND="dev-php/pear"
+HOMEPAGE="http://pear.php.net/package/Structures_Graph"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto /usr/share/php
+ doins -r Structures
+
+ dohtml -r docs/html/*
+}
diff --git a/dev-php/PEAR-Structures_Graph/metadata.xml b/dev-php/PEAR-Structures_Graph/metadata.xml
new file mode 100644
index 000000000000..fd3dbe39fa64
--- /dev/null
+++ b/dev-php/PEAR-Structures_Graph/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+</pkgmetadata>