summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/PEAR-VersionControl_SVN')
-rw-r--r--dev-php/PEAR-VersionControl_SVN/Manifest1
-rw-r--r--dev-php/PEAR-VersionControl_SVN/PEAR-VersionControl_SVN-0.5.2_p20180314.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-php/PEAR-VersionControl_SVN/Manifest b/dev-php/PEAR-VersionControl_SVN/Manifest
index c941f9ebbbf7..056a281c1db4 100644
--- a/dev-php/PEAR-VersionControl_SVN/Manifest
+++ b/dev-php/PEAR-VersionControl_SVN/Manifest
@@ -1 +1,2 @@
+DIST PEAR-VersionControl_SVN-0.5.2_p20180314.tar.gz 36697 BLAKE2B 998e9c08d19284de2bd723fff07bc4c319ed65b12baad012f5f8e6b283060cd25cdefa5141e71f8368555d963e7ab1eec7b8e41d38cbd9a89dbd6977f72b5102 SHA512 aaba6fcd65d3906c9d98085b109d1357578be7557a9ac5b5997ae9a9896cb0970f3bf707246e5afc68dfbb8268a8fad36265b484220387b56e8de85e390db82a
DIST VersionControl_SVN-0.5.2.tgz 31356 BLAKE2B d59971b0677d3e88b47f1fb249c6ba6971db7b868e390589705058fa0cc19a3b4e7a2da38db78b37a9fa7b8f9233297a4fb5376b1b225c8e93f41bbe65c99007 SHA512 09aaab0461a52fe87e5723472b9978c8f928a4741e11a69672ae1350ecdf90b287d951b8343b5fbfbc1d7cd449055cb249f229a1e943cdcd807e9b36e0a48b86
diff --git a/dev-php/PEAR-VersionControl_SVN/PEAR-VersionControl_SVN-0.5.2_p20180314.ebuild b/dev-php/PEAR-VersionControl_SVN/PEAR-VersionControl_SVN-0.5.2_p20180314.ebuild
new file mode 100644
index 000000000000..e228a7700964
--- /dev/null
+++ b/dev-php/PEAR-VersionControl_SVN/PEAR-VersionControl_SVN-0.5.2_p20180314.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2 vcs-snapshot
+
+DESCRIPTION="Simple OO wrapper interface for the Subversion command-line client"
+SRC_URI="https://github.com/pear/VersionControl_SVN/archive/6c9580df92f0cc77a6eb6fcc216c56913bf308e7.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RDEPEND=""
+DEPEND="test? ( dev-vcs/subversion dev-php/phpunit )"
+S="${WORKDIR}/PEAR-${PHP_PEAR_PKG_NAME}-${PV}"
+
+src_prepare() {
+ einfo "Patching SVN.php and SVN/Command.php to use proper paths by default"
+ sed -i -e 's:/usr/local:/usr:g' VersionControl/SVN.php || die "sed failed"
+ sed -i -e 's:/usr/local:/usr:g' VersionControl/SVN/Command.php || die "sed failed"
+ sed -i 's/ +%d / %i /' tests/resetxml_19910.phpt || die
+ default
+}
+
+src_test() {
+ phpunit tests || die "Tests failed"
+}