summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/libchart/libchart-1.3.ebuild')
-rw-r--r--dev-php/libchart/libchart-1.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-php/libchart/libchart-1.3.ebuild b/dev-php/libchart/libchart-1.3.ebuild
new file mode 100644
index 000000000000..dd6595d35955
--- /dev/null
+++ b/dev-php/libchart/libchart-1.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+DESCRIPTION="Libchart is a chart creation PHP library that is easy to use"
+HOMEPAGE="http://naku.dohcrew.com/libchart"
+SRC_URI="http://libchart.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3 BitstreamVera"
+KEYWORDS="~x86 ~amd64"
+SLOT=0
+IUSE="examples"
+
+DEPEND=""
+RDEPEND="dev-lang/php[truetype]
+ || ( dev-lang/php[gd] dev-lang/php[gd-external] )"
+
+S="${WORKDIR}/${PN}"
+
+src_install() {
+ dodoc "${PN}/ChangeLog" "${PN}/README"
+ rm -f "${PN}/ChangeLog" "${PN}/ChangeLog" "${PN}/COPYING"
+
+ if use examples ; then
+ # no point making users unzip all files individually
+ docompress -x "/usr/share/doc/${PF}/demo"
+ dodoc -r demo/
+ fi
+
+ insinto "/usr/share/php/${PN}"
+ doins -r ${PN}
+}