summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/libvirt-php/libvirt-php-0.5.3.ebuild')
-rw-r--r--dev-php/libvirt-php/libvirt-php-0.5.3.ebuild65
1 files changed, 0 insertions, 65 deletions
diff --git a/dev-php/libvirt-php/libvirt-php-0.5.3.ebuild b/dev-php/libvirt-php/libvirt-php-0.5.3.ebuild
deleted file mode 100644
index 4c6eda7c043c..000000000000
--- a/dev-php/libvirt-php/libvirt-php-0.5.3.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PHP_EXT_NAME="libvirt-php"
-PHP_EXT_SKIP_PHPIZE="yes"
-USE_PHP="php5-6 php7-0 php7-1"
-PHP_EXT_ECONF_ARGS=()
-
-inherit php-ext-source-r3 autotools
-
-DESCRIPTION="PHP bindings for libvirt"
-HOMEPAGE="http://libvirt.org/php/"
-SRC_URI="http://libvirt.org/sources/php/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="doc"
-
-RDEPEND="app-emulation/libvirt
- dev-libs/libxml2"
-DEPEND="${RDEPEND}
- dev-libs/libxslt
- virtual/pkgconfig
- doc? ( app-text/xhtml1 )"
-
-RESTRICT="test"
-DOCS=( AUTHORS ChangeLog NEWS README )
-# Remove the insane check for pecl-imagick which is only used in examples
-# and is not called upon in any build
-PATCHES=( "${FILESDIR}/remove-imagick-check.patch" )
-
-src_unpack() {
- default
-
- # create the default modules directory to be able
- # to use the php-ext-source-r3 eclass to configure/build
- ln -s src "${S}/modules"
-}
-
-src_prepare() {
- php-ext-source-r3_src_prepare
- local slot
- for slot in $(php_get_slots); do
- php_init_slot_env "${slot}"
- eautoreconf
- done
-}
-
-src_install() {
- local slot
- for slot in $(php_get_slots); do
- php_init_slot_env ${slot}
- insinto "${EXT_DIR}"
- doins "src/.libs/${PHP_EXT_NAME}.so"
- done
- php-ext-source-r3_createinifiles
- einstalldocs
- if use doc ; then
- docinto /usr/share/doc/${PF}/html
- dodoc -r docs/*
- fi
-}