summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/pecl-eio/pecl-eio-2.0.4.ebuild')
-rw-r--r--dev-php/pecl-eio/pecl-eio-2.0.4.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-php/pecl-eio/pecl-eio-2.0.4.ebuild b/dev-php/pecl-eio/pecl-eio-2.0.4.ebuild
new file mode 100644
index 000000000000..571ac16c43fb
--- /dev/null
+++ b/dev-php/pecl-eio/pecl-eio-2.0.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PHP_EXT_NAME="eio"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS=( README.md )
+
+USE_PHP="php5-6 php7-0 php7-1 php7-2 php7-3"
+inherit php-ext-pecl-r3
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="PHP-3.01"
+
+DESCRIPTION="PHP wrapper for libeio library"
+LICENSE="PHP-3"
+SLOT="0"
+IUSE="debug"
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS="--with-eio $(use_enable debug eio-debug)"
+ php-ext-source-r3_src_configure
+}