summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/pecl-http')
-rw-r--r--dev-php/pecl-http/Manifest1
-rw-r--r--dev-php/pecl-http/pecl-http-1.7.6-r2.ebuild62
-rw-r--r--dev-php/pecl-http/pecl-http-1.7.6-r3.ebuild69
3 files changed, 0 insertions, 132 deletions
diff --git a/dev-php/pecl-http/Manifest b/dev-php/pecl-http/Manifest
index 994e37bccb8c..d3339f248e96 100644
--- a/dev-php/pecl-http/Manifest
+++ b/dev-php/pecl-http/Manifest
@@ -1,3 +1,2 @@
-DIST pecl_http-1.7.6.tgz 174722 SHA256 e87207a7dcd713bef0eb3701b552e0d173fbd73dbd52f9d3968851112e899983 SHA512 e548073e08d106c9ee633dc00c2728845e3a1403c065134a0e8111899b52dacb7175cea836e19da8cf2b7f42fe58c084602003bb79f16d529bc109c39a78bbca WHIRLPOOL 778bd7f1a0bb1698c4a6a8745a40ea5c757ade6cfc027b99bd10f92cc3b111ceb7887a582216c8a303a2ce8edfc90c653b4c055b057691f873c2e3dbd78f740a
DIST pecl_http-2.5.6.tgz 200469 SHA256 8435eb9082b8fdc56b630e3d3d8e63617a3bc43d360f6f49fbd7b1856b266be4 SHA512 a4ddb2e55b537a240dc79ad38665f9cb79ef56a70f50e0393ca19c36f744c21374ba801e31e68545516c4be98cff65587ee91b2b25f05dd587120afcb87dfe4a WHIRLPOOL d4d2158b610c959a558b450a79a77a7f9de53d6e75982e920c4b64d48731139223659af149b9894c2fee1a477005af34a57cb33a806429e11446d5162b031b89
DIST pecl_http-3.0.1.tgz 197372 SHA256 4e45ea546e3245669887ec98187666ccb4aa3df15078335b1c02c824c8165031 SHA512 344ae45987269d9505ffed6059be378005298d89c5e39bda6f771d8bf5a1998e91c214c03d32b9c78329c95e4928d35d3659dd3a1c70071aa5b2bd2763852098 WHIRLPOOL 76538ec0b94ef5d63808b625a8e73ab499c2afc78cd0f31823dcea4de66d865f7cf8387cc67eac1f19fec032a7ac7b7775685048ac0c6f76fadccfc1d932026c
diff --git a/dev-php/pecl-http/pecl-http-1.7.6-r2.ebuild b/dev-php/pecl-http/pecl-http-1.7.6-r2.ebuild
deleted file mode 100644
index 3dde9ed5dee4..000000000000
--- a/dev-php/pecl-http/pecl-http-1.7.6-r2.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-PHP_EXT_NAME="http"
-PHP_EXT_PECL_PKG="pecl_http"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-DOCS="docs/examples/tutorial.txt ThanksTo.txt KnownIssues.txt"
-
-# Does not compile with php5-6
-USE_PHP="php5-5 php5-4"
-
-inherit php-ext-pecl-r2 php-ext-source-r2
-
-KEYWORDS="amd64 x86"
-
-DESCRIPTION="Extended HTTP Support for PHP"
-LICENSE="BSD-2 MIT"
-SLOT="0"
-IUSE=""
-
-DEPEND="net-misc/curl
- sys-libs/zlib
- dev-libs/libevent
- dev-lang/php[hash,session,iconv]
- "
-RDEPEND="${DEPEND}"
-
-my_conf="--enable-http \
- --with-http-curl-requests \
- --with-http-zlib-compression \
- --with-http-curl-libevent \
- --with-http-magic-mime"
-
-src_install() {
- php-ext-pecl-r2_src_install
-
- php-ext-source-r2_addtoinifiles "http.etag.mode" "MD5"
- php-ext-source-r2_addtoinifiles "http.force_exit" "1"
- php-ext-source-r2_addtoinifiles "http.log.allowed_methods" ""
- php-ext-source-r2_addtoinifiles "http.log.cache" ""
- php-ext-source-r2_addtoinifiles "http.log.composite" ""
- php-ext-source-r2_addtoinifiles "http.log.not_found" ""
- php-ext-source-r2_addtoinifiles "http.log.redirect" ""
- php-ext-source-r2_addtoinifiles "http.only_exceptions" "0"
- php-ext-source-r2_addtoinifiles "http.persistent.handles.ident" "GLOBAL"
- php-ext-source-r2_addtoinifiles "http.persistent.handles.limit" "-1"
- php-ext-source-r2_addtoinifiles "http.request.datashare.connect" "0"
- php-ext-source-r2_addtoinifiles "http.request.datashare.cookie" "0"
- php-ext-source-r2_addtoinifiles "http.request.datashare.dns" "1"
- php-ext-source-r2_addtoinifiles "http.request.datashare.ssl" "0"
- php-ext-source-r2_addtoinifiles "http.request.methods.allowed" ""
- php-ext-source-r2_addtoinifiles "http.request.methods.custom" ""
- php-ext-source-r2_addtoinifiles "http.send.inflate.start_auto" "0"
- php-ext-source-r2_addtoinifiles "http.send.inflate.start_flags" "0"
- php-ext-source-r2_addtoinifiles "http.send.deflate.start_auto" "0"
- php-ext-source-r2_addtoinifiles "http.send.deflate.start_flags" "0"
- php-ext-source-r2_addtoinifiles "http.send.not_found_404" "1"
-}
diff --git a/dev-php/pecl-http/pecl-http-1.7.6-r3.ebuild b/dev-php/pecl-http/pecl-http-1.7.6-r3.ebuild
deleted file mode 100644
index fa6f8d5341d6..000000000000
--- a/dev-php/pecl-http/pecl-http-1.7.6-r3.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-PHP_EXT_NAME="http"
-PHP_EXT_PECL_PKG="pecl_http"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-DOCS="docs/examples/tutorial.txt ThanksTo.txt KnownIssues.txt"
-
-# Does not compile with php5-6
-USE_PHP="php5-5 php5-4"
-
-inherit php-ext-pecl-r2 php-ext-source-r2
-
-KEYWORDS="~amd64 ~x86"
-
-DESCRIPTION="Extended HTTP Support for PHP"
-LICENSE="BSD-2 MIT"
-SLOT="0"
-IUSE=""
-
-for target in ${USE_PHP}; do
- slot=${target/php}
- slot=${slot/-/.}
- PHPUSEDEPEND="${PHPUSEDEPEND}
- php_targets_${target}? ( dev-lang/php:${slot}[hash,session,iconv] )"
-done
-
-DEPEND="net-misc/curl
- sys-libs/zlib
- dev-libs/libevent
- ${PHPUSEDEPEND}
- "
-RDEPEND="${DEPEND}"
-
-my_conf="--enable-http \
- --with-http-curl-requests \
- --with-http-zlib-compression \
- --with-http-curl-libevent \
- --with-http-magic-mime"
-
-src_install() {
- php-ext-pecl-r2_src_install
-
- php-ext-source-r2_addtoinifiles "http.etag.mode" "MD5"
- php-ext-source-r2_addtoinifiles "http.force_exit" "1"
- php-ext-source-r2_addtoinifiles "http.log.allowed_methods" ""
- php-ext-source-r2_addtoinifiles "http.log.cache" ""
- php-ext-source-r2_addtoinifiles "http.log.composite" ""
- php-ext-source-r2_addtoinifiles "http.log.not_found" ""
- php-ext-source-r2_addtoinifiles "http.log.redirect" ""
- php-ext-source-r2_addtoinifiles "http.only_exceptions" "0"
- php-ext-source-r2_addtoinifiles "http.persistent.handles.ident" "GLOBAL"
- php-ext-source-r2_addtoinifiles "http.persistent.handles.limit" "-1"
- php-ext-source-r2_addtoinifiles "http.request.datashare.connect" "0"
- php-ext-source-r2_addtoinifiles "http.request.datashare.cookie" "0"
- php-ext-source-r2_addtoinifiles "http.request.datashare.dns" "1"
- php-ext-source-r2_addtoinifiles "http.request.datashare.ssl" "0"
- php-ext-source-r2_addtoinifiles "http.request.methods.allowed" ""
- php-ext-source-r2_addtoinifiles "http.request.methods.custom" ""
- php-ext-source-r2_addtoinifiles "http.send.inflate.start_auto" "0"
- php-ext-source-r2_addtoinifiles "http.send.inflate.start_flags" "0"
- php-ext-source-r2_addtoinifiles "http.send.deflate.start_auto" "0"
- php-ext-source-r2_addtoinifiles "http.send.deflate.start_flags" "0"
- php-ext-source-r2_addtoinifiles "http.send.not_found_404" "1"
-}