summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/pecl-http')
-rw-r--r--dev-php/pecl-http/Manifest1
-rw-r--r--dev-php/pecl-http/pecl-http-3.2.0.ebuild75
2 files changed, 0 insertions, 76 deletions
diff --git a/dev-php/pecl-http/Manifest b/dev-php/pecl-http/Manifest
index 5815a02fe4a7..bf0b8fdd6cfb 100644
--- a/dev-php/pecl-http/Manifest
+++ b/dev-php/pecl-http/Manifest
@@ -1,4 +1,3 @@
DIST pecl_http-2.6.0.tgz 217673 BLAKE2B a7147924cfc018c3e273d85666d9792ea614955d0aa20ac43171266d91d139dccdbf2472dec4d145b798ce99a541dba48f7bed6009fbdf2a7ad81ab322963788 SHA512 12d18049411a4133008449a1e7458a3055322dc337f421e0e2be126ec965f15b0189af6fccd9ca4537c48819c763b9e020906ac6d09d87ead92f4436fac595ad
-DIST pecl_http-3.2.0.tgz 218829 BLAKE2B bbd6f9fe8afb4324d928496e1fbcdd455e8bff5e45312ba65e5e9263719b098763203de055ea8a8ff6202ae4a434d37db25bb0975faacc956af4a0c6e8bfe8a1 SHA512 59738ee52370c68f7e74349d52738da845cfb83ae27b51a2caf3b048ba0b37c897702d7f5f8e0517df5612fd2e904d02e8e24c9e649a9e7cfdcdc04e9d19b113
DIST pecl_http-3.2.1.tgz 221244 BLAKE2B b6581829fb8a800e24ccedd4d0f3efbaf558850bdc356d27a6e1d1097a8e2cfc61963a1daccd1d0f269a7cef5b243d45cdfaff5138321fe20df615dde44d19e3 SHA512 e67d4b32ba6f524e3fcf65f5497b94275e1a4a14fce97c57afe366369f368b3acdbedf364ed73cf983fb2c5f57f498adaa1100e7c936f11cbc5de1caedad7b51
DIST pecl_http-3.2.3.tgz 220204 BLAKE2B 2a712dc8f69a8a80f6f8c306883df580fdff4a0d4cb0ac06cc004f8622b30b8e2f5d373276381fd3ad67657a80cc929be81745f200a98b6ed5e475de5639dfc5 SHA512 e955e3246db9a9172081dd9a077154139c585bfce546e91839052bbab4d0db9d0695122574a66891ceba5c0b7e8a8f0768274e1516521ccb95cd19504dc13666
diff --git a/dev-php/pecl-http/pecl-http-3.2.0.ebuild b/dev-php/pecl-http/pecl-http-3.2.0.ebuild
deleted file mode 100644
index b17e8e396289..000000000000
--- a/dev-php/pecl-http/pecl-http-3.2.0.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PHP_EXT_NAME="http"
-PHP_EXT_PECL_PKG="pecl_http"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-PHP_INI_NAME="50-http"
-
-USE_PHP="php5-6 php7-1 php7-2 php7-3"
-
-inherit php-ext-pecl-r3
-
-USE_PHP="php7-1 php7-2 php7-3"
-
-KEYWORDS="~amd64 ~x86"
-
-DESCRIPTION="Extended HTTP Support for PHP"
-LICENSE="BSD-2 MIT"
-SLOT="7"
-IUSE="ssl curl_ssl_gnutls curl_ssl_libressl curl_ssl_nss +curl_ssl_openssl"
-
-DEPEND="app-arch/brotli:=
- dev-libs/libevent
- dev-php/pecl-propro:7[php_targets_php7-1?,php_targets_php7-2?,php_targets_php7-3?]
- dev-php/pecl-raphf:7[php_targets_php7-1?,php_targets_php7-2?,php_targets_php7-3?]
- net-dns/libidn2
- sys-libs/zlib
- ssl? ( net-misc/curl[ssl,curl_ssl_gnutls=,curl_ssl_libressl=,curl_ssl_nss=,curl_ssl_openssl=] )
- !ssl? ( net-misc/curl[-ssl] )
- php_targets_php7-1? ( dev-lang/php:7.1[hash,session,iconv] )
- php_targets_php7-2? ( dev-lang/php:7.2[hash,session,iconv] )
- php_targets_php7-3? ( dev-lang/php:7.3[hash,session,iconv] )"
-RDEPEND="${DEPEND}
- php_targets_php5-6? ( dev-php/pecl-http:2[php_targets_php5-6] )"
-
-PHP_EXT_ECONF_ARGS=( --with-http --without-http-shared-deps --without-http-libidn-dir )
-
-src_prepare() {
- if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
- php-ext-source-r3_src_prepare
- else
- default_src_prepare
- fi
-}
-
-src_install() {
- if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
- php-ext-pecl-r3_src_install
- fi
-}
-
-src_test() {
- # Cannot use eclass function due to required modules
- # All tests SKIP otherwise
- for slot in $(php_get_slots); do
- php_init_slot_env "${slot}"
- # Link in required modules for testing
- ln -s "${EXT_DIR}/propro.so" "modules/propro.so" || die
- ln -s "${EXT_DIR}/raphf.so" "modules/raphf.so" || die
- sed -i \
- 's/PHP_TEST_SHARED_EXTENSIONS)/PHP_TEST_SHARED_EXTENSIONS) -d extension=propro.so -d extension=raphf.so/' \
- Makefile || die
- NO_INTERACTION="yes" emake test
- # Clean up testing links
- rm modules/propro.so modules/raphf.so || die
- done
-}
-
-pkg_postinst() {
- ewarn "This API has drastically changed and is not compatible with the 1.x syntax."
- ewarn "Please review the documentation and update your code."
-}