summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/pecl-redis/pecl-redis-2.2.3.ebuild')
-rw-r--r--dev-php/pecl-redis/pecl-redis-2.2.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-php/pecl-redis/pecl-redis-2.2.3.ebuild b/dev-php/pecl-redis/pecl-redis-2.2.3.ebuild
new file mode 100644
index 000000000000..56f8f55e754f
--- /dev/null
+++ b/dev-php/pecl-redis/pecl-redis-2.2.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PHP_EXT_NAME="redis"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+USE_PHP="php5-5 php5-4"
+
+DOCS="README ChangeLog"
+
+inherit php-ext-pecl-r2
+
+KEYWORDS="amd64"
+
+DESCRIPTION="This extension provides an API for communicating with Redis servers"
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE="igbinary"
+
+DEPEND="igbinary? ( dev-php/igbinary )"
+RDEPEND="$DEPEND"
+
+src_configure() {
+ my_conf="--enable-redis
+ $(use_enable igbinary redis-igbinary)"
+
+ php-ext-source-r2_src_configure
+}