summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/phpDocumentor/phpDocumentor-2.3.0.ebuild')
-rw-r--r--dev-php/phpDocumentor/phpDocumentor-2.3.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-php/phpDocumentor/phpDocumentor-2.3.0.ebuild b/dev-php/phpDocumentor/phpDocumentor-2.3.0.ebuild
new file mode 100644
index 000000000000..09ed0de86a70
--- /dev/null
+++ b/dev-php/phpDocumentor/phpDocumentor-2.3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PHP_PEAR_URI="pear.phpdoc.org"
+
+inherit php-pear-r1
+
+DESCRIPTION="The phpDocumentor package provides automatic documenting of php api directly from the source"
+
+LICENSE="MIT"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+# block old version that provides the same binary
+DEPEND="!dev-php/PEAR-PhpDocumentor"
+RDEPEND="media-gfx/graphviz
+ dev-lang/php[iconv,intl,xslt]"
+
+src_install() {
+ php-pear-r1_src_install
+
+ # install manual, tutorial, reference material
+ use doc && dodoc -r docs/*
+}