summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/symfony-filesystem/Manifest1
-rw-r--r--dev-php/symfony-filesystem/files/autoload.php8
-rw-r--r--dev-php/symfony-filesystem/metadata.xml15
-rw-r--r--dev-php/symfony-filesystem/symfony-filesystem-2.7.20.ebuild25
4 files changed, 49 insertions, 0 deletions
diff --git a/dev-php/symfony-filesystem/Manifest b/dev-php/symfony-filesystem/Manifest
new file mode 100644
index 000000000000..88c1b8e1cc7a
--- /dev/null
+++ b/dev-php/symfony-filesystem/Manifest
@@ -0,0 +1 @@
+DIST symfony-filesystem-2.7.20.tar.gz 13679 SHA256 b08c32bf2340bc7b107ec4fdff2d32634528655991e4331d4b4d72e68e816674 SHA512 ebab6760aa38577162da6d12f4c83bf1ef5fad961cc979986e1f23c6624d80099fe3853bd0dc8113b06d8258fe1b34a4a34fa737048fa500751a63a425018359 WHIRLPOOL a65c1de2a6b98713e8aaa23fa4d3fce13f5c4c15dddf7669f9e9474ff87db5c21397a66520ffebc3e6bdaa4252e6cc61e774c4ff746907efd5a266810f47fb07
diff --git a/dev-php/symfony-filesystem/files/autoload.php b/dev-php/symfony-filesystem/files/autoload.php
new file mode 100644
index 000000000000..8ea8655d904f
--- /dev/null
+++ b/dev-php/symfony-filesystem/files/autoload.php
@@ -0,0 +1,8 @@
+<?php
+/* Autoloader for symfony-filesystem and its dependencies */
+
+if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
+ require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
+}
+
+\Fedora\Autoloader\Autoload::addPsr4('Symfony\\Component\\Filesystem\\', __DIR__);
diff --git a/dev-php/symfony-filesystem/metadata.xml b/dev-php/symfony-filesystem/metadata.xml
new file mode 100644
index 000000000000..3a8403a91753
--- /dev/null
+++ b/dev-php/symfony-filesystem/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>guillaumeseren@gmail.com</email>
+ <name>Guillaume Seren</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ The Filesystem component provides basic utilities for the filesystem.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-php/symfony-filesystem/symfony-filesystem-2.7.20.ebuild b/dev-php/symfony-filesystem/symfony-filesystem-2.7.20.ebuild
new file mode 100644
index 000000000000..1e8dc8042629
--- /dev/null
+++ b/dev-php/symfony-filesystem/symfony-filesystem-2.7.20.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Symfony Filesystem Component"
+HOMEPAGE="https://github.com/symfony/filesystem"
+SRC_URI="https://github.com/symfony/filesystem/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/php:*
+ dev-php/fedora-autoloader"
+
+S="${WORKDIR}/filesystem-${PV}"
+
+src_install() {
+ insinto "/usr/share/php/Symfony/Component/Filesystem"
+ doins -r . "${FILESDIR}"/autoload.php
+ dodoc README.md
+}