summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/BitVector/BitVector-3.4.6.ebuild')
-rw-r--r--dev-python/BitVector/BitVector-3.4.6.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/BitVector/BitVector-3.4.6.ebuild b/dev-python/BitVector/BitVector-3.4.6.ebuild
new file mode 100644
index 000000000000..05c03159bd20
--- /dev/null
+++ b/dev-python/BitVector/BitVector-3.4.6.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure-Python memory-efficient packed representation for bit arrays"
+HOMEPAGE="http://cobweb.ecn.purdue.edu/~kak/dist/ https://pypi.python.org/pypi/BitVector"
+SRC_URI="http://cobweb.ecn.purdue.edu/~kak/dist/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+python_test() {
+ "${PYTHON}" TestBitVector/Test.py || die "Tests fail with ${EPYTHON}"
+}