summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/apsw')
-rw-r--r--dev-python/apsw/Manifest1
-rw-r--r--dev-python/apsw/apsw-3.11.1_p1.ebuild43
-rw-r--r--dev-python/apsw/metadata.xml11
3 files changed, 50 insertions, 5 deletions
diff --git a/dev-python/apsw/Manifest b/dev-python/apsw/Manifest
index 71837153d899..71f6fa36a6de 100644
--- a/dev-python/apsw/Manifest
+++ b/dev-python/apsw/Manifest
@@ -1,3 +1,4 @@
+DIST apsw-3.11.1_p1.zip 679045 SHA256 92685d555bb5bdbf5ec85563cd826f76630c33a589ef2528e8f14f73a8bcc95f SHA512 3976b14ade967b2e39fdd18436e7a9a2f8f4f5b289ee93725878bd8bfa15ccb7548156df8cca981f494a4cdcc7aaed5370fde2b805e6eea022892ece1231bd96 WHIRLPOOL 8ad615ba3b5f15cdd36c15a370b036a4fddf92b69b6b0058d3fdf8d83bd2b39251d11b3cd291319c08ad09baf3f26d1b0cff3d54777e6c7169e335e985a0d1e9
DIST apsw-3.8.10.1_p1.tar.gz 307142 SHA256 af20221e1a65f593b47d83f1f8a136afc6d2199a22bc014251a44e31e7b0ca17 SHA512 1f997c6c88ca65995c8b5d894135d5900a4d2f56f877f74f0e99eab4ede0d06be5730ce282a5d99358318ca076eec75f2afe271574b6c02aaabf4bef181d0bda WHIRLPOOL 3e9b609a19ee39edda9af8140982c74d53d3e2b4c0bd05ea53974cb7a3c2f12f13ab4acf1d51ac5b50ee738f5380dc83b819e0ed11bf28107f903f0a52eb5949
DIST apsw-3.8.11.1_p1.tar.gz 307797 SHA256 f4dc653aca10dfae8578c8bf1125600f77d0d8dcc85b4185754388aa87ae0997 SHA512 4ca857d32f423475b17e81130d4919627d581b80dd6f3f120d95906ddad657d6f52eb69fb211612e15f5eaee0211c0ad992391c93068a463e72670d49f69c61e WHIRLPOOL 15a58a83e1e5f3ee4afc470a0d58e29f5ee5cf416897b1c83ad021fb9c47f0533a5e01417aa59fb74e7b33ad9e5f1a74b40c0cbffcee4cf01617006dbad3dc2a
DIST apsw-3.8.7.1_p1.tar.gz 303446 SHA256 7aee29cc170332aa1a16fb80753152e809208bbc91823f64178e4afc32526fec SHA512 104aad3a8cec07647b71c77814cc069587daf84450b41f992d0b3c752c476105351b28912768a29f7952bfd75e9b2d3fcd8e6ae758b3bab8b986bf8e1300c256 WHIRLPOOL cc95728b07e384ee88002afce4b68abcfb259a62188cc77bad1154a83bf3e1979fec8761fe8a3c9e5ae35d5027cdf42c1b4a4b7749ad76d7935e032e253c8167
diff --git a/dev-python/apsw/apsw-3.11.1_p1.ebuild b/dev-python/apsw/apsw-3.11.1_p1.ebuild
new file mode 100644
index 000000000000..de24957145ad
--- /dev/null
+++ b/dev-python/apsw/apsw-3.11.1_p1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+
+inherit distutils-r1 flag-o-matic
+
+MY_PV=${PV/_p/-r}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="APSW - Another Python SQLite Wrapper"
+HOMEPAGE="https://github.com/rogerbinns/apsw/"
+SRC_URI="https://github.com/rogerbinns/apsw/releases/download/${MY_PV}/${MY_P}.zip -> ${P}.zip"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-db/sqlite-${PV%_p*}"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=( "${FILESDIR}/${PN}-3.6.20.1-fix_tests.patch" )
+
+python_compile() {
+ python_is_python3 || append-cflags -fno-strict-aliasing
+ distutils-r1_python_compile --enable=load_extension
+}
+
+python_test() {
+ "${PYTHON}" setup.py build_test_extension || die "Building of test loadable extension failed"
+ "${PYTHON}" tests.py -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/apsw/metadata.xml b/dev-python/apsw/metadata.xml
index b6b8d82c6952..bd25419f6171 100644
--- a/dev-python/apsw/metadata.xml
+++ b/dev-python/apsw/metadata.xml
@@ -5,12 +5,13 @@
<email>python@gentoo.org</email>
<name>Python</name>
</maintainer>
- <longdescription>APSW provides an SQLite 3 wrapper that provides the thinnest layer over SQLite 3 possible.
-Everything you can do from the C API to SQLite 3, you can do from Python.
-Although APSW looks vaguely similar to the DBAPI, it is not compliant with that API and instead
-works the way SQLite 3 does.</longdescription>
+ <longdescription>
+ APSW provides an SQLite 3 wrapper that provides the thinnest layer over SQLite 3 possible.
+ Everything you can do from the C API to SQLite 3, you can do from Python.
+ Although APSW looks vaguely similar to the DBAPI, it is not compliant with that API and instead
+ works the way SQLite 3 does.
+ </longdescription>
<upstream>
- <remote-id type="google-code">apsw</remote-id>
<remote-id type="github">rogerbinns/apsw</remote-id>
</upstream>
</pkgmetadata>