summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cerberus/cerberus-1.3.2.ebuild')
-rw-r--r--dev-python/cerberus/cerberus-1.3.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/cerberus/cerberus-1.3.2.ebuild b/dev-python/cerberus/cerberus-1.3.2.ebuild
new file mode 100644
index 000000000000..d4378677e3d7
--- /dev/null
+++ b/dev-python/cerberus/cerberus-1.3.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="A lightweight and extensible data-validation library for Python"
+HOMEPAGE="https://docs.python-cerberus.org/"
+SRC_URI="https://github.com/pyeve/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.2_no-pytest-runner.patch
+ "${FILESDIR}"/${PN}-1.3.2_test-installation.patch
+)
+
+distutils_enable_tests pytest