summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/clang-python/clang-python-7.0.0.ebuild')
-rw-r--r--dev-python/clang-python/clang-python-7.0.0.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/dev-python/clang-python/clang-python-7.0.0.ebuild b/dev-python/clang-python/clang-python-7.0.0.ebuild
index 5d6eaf45c6cd..6587ca010e17 100644
--- a/dev-python/clang-python/clang-python-7.0.0.ebuild
+++ b/dev-python/clang-python/clang-python-7.0.0.ebuild
@@ -29,6 +29,12 @@ DEPEND="${RDEPEND}"
S=${WORKDIR}/${MY_P}/bindings/python
+PATCHES=(
+ # update completion test results due to completion changes
+ # https://reviews.llvm.org/D50171
+ "${FILESDIR}"/9999/0001-python-tests-Update-test_code_completion.patch
+)
+
src_unpack() {
einfo "Unpacking parts of ${MY_P}.tar.xz ..."
tar -xJf "${DISTDIR}/${MY_P}.tar.xz" "${MY_P}/bindings/python" || die