summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/clint/clint-0.4.1.ebuild')
-rw-r--r--dev-python/clint/clint-0.4.1.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/clint/clint-0.4.1.ebuild b/dev-python/clint/clint-0.4.1.ebuild
deleted file mode 100644
index f62ce78024e5..000000000000
--- a/dev-python/clint/clint-0.4.1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 python3_4 )
-
-inherit distutils-r1 vcs-snapshot
-
-DESCRIPTION="Python Command-line Application Tools"
-HOMEPAGE="https://github.com/kennethreitz/clint"
-SRC_URI="https://github.com/kennethreitz/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="ISC"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE="doc examples test"
-
-DEPEND="
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-RDEPEND="dev-python/args[${PYTHON_USEDEP}]"
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- py.test || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- use examples && local EXAMPLES=( examples/. )
-
- distutils-r1_python_install_all
-}