summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/configargparse/configargparse-0.15.1.ebuild')
-rw-r--r--dev-python/configargparse/configargparse-0.15.1.ebuild31
1 files changed, 0 insertions, 31 deletions
diff --git a/dev-python/configargparse/configargparse-0.15.1.ebuild b/dev-python/configargparse/configargparse-0.15.1.ebuild
deleted file mode 100644
index cffd852dc51a..000000000000
--- a/dev-python/configargparse/configargparse-0.15.1.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MY_PN="ConfigArgParse"
-MY_P="${MY_PN}-${PV}"
-
-PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7,3_8} )
-
-inherit distutils-r1
-
-DESCRIPTION="Drop-in replacement for argparse supporting config files and env variables"
-HOMEPAGE="https://github.com/zorro3/ConfigArgParse https://pypi.org/project/ConfigArgParse/"
-#SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-SRC_URI="https://github.com/zorro3/ConfigArgParse/archive/${PV}.tar.gz -> ${MY_P}.gh.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- test? ( dev-python/pyyaml[${PYTHON_USEDEP}] )"
-
-python_test() {
- local -x COLUMNS=80
- esetup.py test
-}