summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cssutils')
-rw-r--r--dev-python/cssutils/Manifest2
-rw-r--r--dev-python/cssutils/cssutils-0.9.10-r1.ebuild46
-rw-r--r--dev-python/cssutils/cssutils-1.0.ebuild49
-rw-r--r--dev-python/cssutils/metadata.xml17
4 files changed, 114 insertions, 0 deletions
diff --git a/dev-python/cssutils/Manifest b/dev-python/cssutils/Manifest
new file mode 100644
index 000000000000..dccbcc846cb5
--- /dev/null
+++ b/dev-python/cssutils/Manifest
@@ -0,0 +1,2 @@
+DIST cssutils-0.9.10.tar.gz 622919 SHA256 08e2481f53d57e27fffb781bf8c313132c1079b8b1c18ff4f633f2df47011ca6 SHA512 c8fabc808a6d31f0d4a1b48b566277a15bb91974eb797d11d857b05e9e548e03d510d90265e43b9fa9b173eccb5f571c9306bda57c2515878e646b2be32b736e WHIRLPOOL 8d8455b5c6a0fb49d87c7097169c2670e7a2e09ade9fcaa70344a6aab70d7420e3e982488eb88ef118457936d9f917080ea576b879905ebff7dc8bf47815c9b2
+DIST cssutils-1.0.tar.gz 622909 SHA256 050f4e78a9c24a619cbb15c395105e73f3b3bec0204991a6d5e2f8bcca031753 SHA512 673e1de1028acbc8e3fe298b88207da73ee704b7eb89eb22d4606d5086c46a943e3bb48d2ba9b5a1685a253553bbd13d89f41546dca3deaf2d54d8d6f61f9b65 WHIRLPOOL 726a5f557e70bdc612ca70b8203ecf1670c4385eaf5c77aa3b21c3a13e80928e38fc7766efa2ae682a52b0a890675f5746190e0740389dee5427740bab817bff
diff --git a/dev-python/cssutils/cssutils-0.9.10-r1.ebuild b/dev-python/cssutils/cssutils-0.9.10-r1.ebuild
new file mode 100644
index 000000000000..1e6dba203338
--- /dev/null
+++ b/dev-python/cssutils/cssutils-0.9.10-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="A CSS Cascading Style Sheets library"
+HOMEPAGE="http://pypi.python.org/pypi/cssutils/ https://bitbucket.org/cthedot/cssutils"
+# Missing test data
+# https://bitbucket.org/cthedot/cssutils/pull-request/11
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+HG_COMMIT="6fbc1877f6089610b733a92d21c2bbf25dc1ca28"
+SRC_URI="https://bitbucket.org/cthedot/cssutils/get/${HG_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc x86"
+IUSE="examples test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Disable test failing with dev-python/pyxml installed.
+ if has_version dev-python/pyxml; then
+ sed -e "s/test_linecol/_&/" -i src/tests/test_errorhandler.py
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ ln -s "${S}/sheets" "${BUILD_DIR}/sheets" || die
+ set -- nosetests -P "${BUILD_DIR}/lib/cssutils/tests"
+ echo "$@"
+ "$@" || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/cssutils/cssutils-1.0.ebuild b/dev-python/cssutils/cssutils-1.0.ebuild
new file mode 100644
index 000000000000..6b5a065fe0ae
--- /dev/null
+++ b/dev-python/cssutils/cssutils-1.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="A CSS Cascading Style Sheets library"
+HOMEPAGE="http://pypi.python.org/pypi/cssutils/ https://bitbucket.org/cthedot/cssutils"
+# Missing test data
+# https://bitbucket.org/cthedot/cssutils/pull-request/11
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+HG_COMMIT="6fbc1877f6089610b733a92d21c2bbf25dc1ca28"
+SRC_URI="https://bitbucket.org/cthedot/cssutils/get/${HG_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="examples test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Disable test failing with dev-python/pyxml installed.
+ if has_version dev-python/pyxml; then
+ sed -e "s/test_linecol/_&/" -i src/tests/test_errorhandler.py
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ ln -s "${S}/sheets" "${BUILD_DIR}/sheets" || die
+ # exclude tests that connect to the network
+ set -- nosetests \
+ -e test_parseUrl -e test_handlers -P "${BUILD_DIR}/lib/cssutils/tests"
+ echo "$@"
+ "$@" || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/cssutils/metadata.xml b/dev-python/cssutils/metadata.xml
new file mode 100644
index 000000000000..596676e6bf4e
--- /dev/null
+++ b/dev-python/cssutils/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>lordvan@gentoo.org</email>
+ <name>Thomas Raschbacher</name>
+ </maintainer>
+ <longdescription lang="en">
+A Python package to parse and build CSS Cascading Style Sheets.
+</longdescription>
+ <upstream>
+ <remote-id type="google-code">cssutils</remote-id>
+ <remote-id type="pypi">cssutils</remote-id>
+ <remote-id type="bitbucket">cthedot/cssutils</remote-id>
+ </upstream>
+</pkgmetadata>