summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cython/cython-0.29.19.ebuild')
-rw-r--r--dev-python/cython/cython-0.29.19.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/dev-python/cython/cython-0.29.19.ebuild b/dev-python/cython/cython-0.29.19.ebuild
index 187187f52342..8b4b6e7acc61 100644
--- a/dev-python/cython/cython-0.29.19.ebuild
+++ b/dev-python/cython/cython-0.29.19.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1 toolchain-funcs elisp-common
@@ -26,7 +26,7 @@ BDEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
$(python_gen_cond_dep 'dev-python/numpy[${PYTHON_USEDEP}]' \
- 'python3*')
+ python3_{6,7,8})
)"
PATCHES=(
@@ -54,6 +54,12 @@ python_compile_all() {
}
python_test() {
+ if [[ ${EPYTHON} == python3.9 ]]; then
+ # https://github.com/cython/cython/issues/3349
+ einfo "Skipping py3.9 due to known failures"
+ return
+ fi
+
tc-export CC
# https://github.com/cython/cython/issues/1911
local -x CFLAGS="${CFLAGS} -fno-strict-overflow"