summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/decorator/decorator-4.4.2.ebuild')
-rw-r--r--dev-python/decorator/decorator-4.4.2.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/decorator/decorator-4.4.2.ebuild b/dev-python/decorator/decorator-4.4.2.ebuild
new file mode 100644
index 000000000000..27010716420b
--- /dev/null
+++ b/dev-python/decorator/decorator-4.4.2.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7,8}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simplifies the usage of decorators for the average programmer"
+HOMEPAGE="https://github.com/micheles/decorator https://pypi.org/project/decorator/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+DOCS=( CHANGES.md )
+
+distutils_enable_tests setup.py