summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/denonavr/denonavr-0.7.8.ebuild')
-rw-r--r--dev-python/denonavr/denonavr-0.7.8.ebuild33
1 files changed, 0 insertions, 33 deletions
diff --git a/dev-python/denonavr/denonavr-0.7.8.ebuild b/dev-python/denonavr/denonavr-0.7.8.ebuild
deleted file mode 100644
index 82e01eee1a36..000000000000
--- a/dev-python/denonavr/denonavr-0.7.8.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{5,6,7} )
-PYTHON_REQ_USE="xml(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Automation Library for Denon AVR receivers"
-HOMEPAGE="https://github.com/scarface-4711/denonavr"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND="dev-python/requests[${PYTHON_USEDEP}]"
-BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/requests-mock[${PYTHON_USEDEP}]
- dev-python/testtools[${PYTHON_USEDEP}]
- )
-"
-
-python_test() {
- pytest -vv || die "tests failed with ${EPYTHON}"
-}