summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/diff-match-patch/diff-match-patch-20230430.ebuild')
-rw-r--r--dev-python/diff-match-patch/diff-match-patch-20230430.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/diff-match-patch/diff-match-patch-20230430.ebuild b/dev-python/diff-match-patch/diff-match-patch-20230430.ebuild
new file mode 100644
index 000000000000..d985a1e8c196
--- /dev/null
+++ b/dev-python/diff-match-patch/diff-match-patch-20230430.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Diff, match and patch algorithms for plain text"
+HOMEPAGE="
+ https://github.com/diff-match-patch-python/diff-match-patch/
+ https://pypi.org/project/diff-match-patch/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 arm64 x86"
+
+distutils_enable_tests pytest