summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/django-celery/django-celery-3.1.16.ebuild')
-rw-r--r--dev-python/django-celery/django-celery-3.1.16.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/dev-python/django-celery/django-celery-3.1.16.ebuild b/dev-python/django-celery/django-celery-3.1.16.ebuild
index 44b6fe2c148d..872f74f4432c 100644
--- a/dev-python/django-celery/django-celery-3.1.16.ebuild
+++ b/dev-python/django-celery/django-celery-3.1.16.ebuild
@@ -3,9 +3,10 @@
# $Id$
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_COMPAT=( python{2_7,3_4} )
+PYTHON_REQ_USE="sqlite(+)"
-inherit distutils-r1
+inherit distutils-r1 eutils
DESCRIPTION="Celery Integration for Django"
HOMEPAGE="http://celeryproject.org/"
@@ -16,9 +17,14 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE="doc examples test"
+# Python testsuite fails when built against dev-python/django-1.8.5
+# with ValueError: save() prohibited to prevent data loss due to
+# unsaved related object 'interval'.
+
PY2_USEDEP=$(python_gen_usedep python2_7)
RDEPEND=">=dev-python/celery-3.1.15[${PYTHON_USEDEP}]
- dev-python/django[${PYTHON_USEDEP}]
+ >dev-python/django-1.4[${PYTHON_USEDEP}]
+ <=dev-python/django-1.7.10[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
@@ -37,6 +43,8 @@ PY27_REQUSE="$(python_gen_useflags 'python2.7')"
REQUIRED_USE="
doc? ( ${PY27_REQUSE} )"
+PATCHES=( "${FILESDIR}/${P}-py3-test-failures.patch" )
+
python_compile_all() {
use doc && emake -C docs html
}