summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/django-otp')
-rw-r--r--dev-python/django-otp/Manifest1
-rw-r--r--dev-python/django-otp/django-otp-0.9.1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/django-otp/Manifest b/dev-python/django-otp/Manifest
index b582ef87c54f..8ab527d30368 100644
--- a/dev-python/django-otp/Manifest
+++ b/dev-python/django-otp/Manifest
@@ -1 +1,2 @@
DIST django-otp-0.9.0.gh.tar.gz 60204 BLAKE2B c71b27e007580410fea3cf8110631801c8c08f7e325c3586cb5a41a9618b371b5d65e3b030a5b483cb6cda684fe837cd40aa1c5d04f54dc82cda750b8ba8aeb9 SHA512 dd3c99e928ebf1ba5b6f6b2f34fcf8a1f86ad64ece17a9bd97c56be239f165808f6d1025e2826a12a8eadc150fe49920a0b7ef398d83542cd97a4a6f391505fe
+DIST django-otp-0.9.1.gh.tar.gz 60230 BLAKE2B 1a912e35f8245d3411fc1a9b26dd53d99df5dba5f2a5f68003bc4d535365af336d8664f81cc42f140247bb0e7150c0a60a3308d96cda1e41681dc93520f112d2 SHA512 600286653c035527a2a7978f19c3b9683805ab4562f12afcc2140adf92705239b8f9141b9979a6c30110cf7f3cc13c67019f39448d3cb8db61c4e1b0cdbcee88
diff --git a/dev-python/django-otp/django-otp-0.9.1.ebuild b/dev-python/django-otp/django-otp-0.9.1.ebuild
new file mode 100644
index 000000000000..4bbf7d96389b
--- /dev/null
+++ b/dev-python/django-otp/django-otp-0.9.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Django framework adding two-factor authentication using one-time passwords"
+HOMEPAGE="https://github.com/django-otp/django-otp/"
+SRC_URI="
+ https://github.com/django-otp/django-otp/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-1.11[${PYTHON_USEDEP}]"
+BDEPEND="test? ( ${RDEPEND} )"
+
+python_test() {
+ local -x PYTHONPATH=test:${PYTHONPATH}
+ local -x DJANGO_SETTINGS_MODULE=test_project.settings
+ django-admin test -v 2 django_otp || die "Tests fail with ${EPYTHON}"
+}