summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/entrypoint2')
-rw-r--r--dev-python/entrypoint2/Manifest2
-rw-r--r--dev-python/entrypoint2/entrypoint2-1.0.ebuild25
-rw-r--r--dev-python/entrypoint2/entrypoint2-1.1.ebuild32
-rw-r--r--dev-python/entrypoint2/metadata.xml6
4 files changed, 36 insertions, 29 deletions
diff --git a/dev-python/entrypoint2/Manifest b/dev-python/entrypoint2/Manifest
index 3bdb0bb2a058..7aad354e11cd 100644
--- a/dev-python/entrypoint2/Manifest
+++ b/dev-python/entrypoint2/Manifest
@@ -1 +1 @@
-DIST entrypoint2-1.0.tar.gz 15424 BLAKE2B 1270a35218cde90922fe8f675917545f4c43e5ec0effd632583cd0bd02200d6a453716787c222722cec633bcb108c1b8c26e284e9659e754d3bc6a77895a6042 SHA512 6580dbf19482af95cbccad61b6f6dc73c068ac78d166e2cea4fae54243921e577316d38e204ad5983f0f52d898d67a10f4c90332d4eeaff1ea713bfc82c70890
+DIST entrypoint2-1.1.gh.tar.gz 15480 BLAKE2B e9a834b863e624971266b78fed75ce2621511f7529f88e4950803c8978a1e27e81585751c25eab82aa1507b6abf8500b11e6ab7ec80052ccd31bec16bf3ed790 SHA512 807b8a53cc5c3e88de971c624dc69b3d526637d84856a0a67fdf2d15c51224cb5c48a7614eaa1942783ce2e954791a86f5ae6eb4dbf1a6e7928161e2cc8f293d
diff --git a/dev-python/entrypoint2/entrypoint2-1.0.ebuild b/dev-python/entrypoint2/entrypoint2-1.0.ebuild
deleted file mode 100644
index 3547ae9dde3c..000000000000
--- a/dev-python/entrypoint2/entrypoint2-1.0.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Easy to use command-line interface for python modules"
-HOMEPAGE="https://github.com/ponty/entrypoint2"
-SRC_URI="https://github.com/ponty/entrypoint2/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-
-BDEPEND="
- test? (
- dev-python/easyprocess[${PYTHON_USEDEP}]
- dev-python/path-py[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
diff --git a/dev-python/entrypoint2/entrypoint2-1.1.ebuild b/dev-python/entrypoint2/entrypoint2-1.1.ebuild
new file mode 100644
index 000000000000..c34a12beceb6
--- /dev/null
+++ b/dev-python/entrypoint2/entrypoint2-1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Easy to use command-line interface for python modules"
+HOMEPAGE="
+ https://github.com/ponty/entrypoint2/
+ https://pypi.org/project/entrypoint2/
+"
+SRC_URI="
+ https://github.com/ponty/entrypoint2/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~riscv x86"
+
+BDEPEND="
+ test? (
+ dev-python/easyprocess[${PYTHON_USEDEP}]
+ dev-python/path[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/entrypoint2/metadata.xml b/dev-python/entrypoint2/metadata.xml
index e27b10d1465d..3df5cf156b15 100644
--- a/dev-python/entrypoint2/metadata.xml
+++ b/dev-python/entrypoint2/metadata.xml
@@ -1,9 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>andrewammerlaan@gentoo.org</email>
- <name>Andrew Ammerlaan</name>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
</maintainer>
<stabilize-allarches/>
<upstream>