summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/expandvars/expandvars-0.12.0.ebuild')
-rw-r--r--dev-python/expandvars/expandvars-0.12.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/expandvars/expandvars-0.12.0.ebuild b/dev-python/expandvars/expandvars-0.12.0.ebuild
new file mode 100644
index 000000000000..b8c4dc9e786e
--- /dev/null
+++ b/dev-python/expandvars/expandvars-0.12.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Expand system variables Unix style"
+HOMEPAGE="
+ https://github.com/sayanarijit/expandvars/
+ https://pypi.org/project/expandvars/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
+
+distutils_enable_tests pytest