summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/fastimport/fastimport-0.9.11.ebuild')
-rw-r--r--dev-python/fastimport/fastimport-0.9.11.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/fastimport/fastimport-0.9.11.ebuild b/dev-python/fastimport/fastimport-0.9.11.ebuild
new file mode 100644
index 000000000000..a000b6debba9
--- /dev/null
+++ b/dev-python/fastimport/fastimport-0.9.11.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for parsing the fastimport VCS serialization format"
+HOMEPAGE="https://github.com/jelmer/python-fastimport"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+python_test() {
+ "${EPYTHON}" -m unittest -v fastimport.tests.test_suite ||
+ die "Tests fail with ${EPYTHON}"
+}