summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/fexpect/fexpect-0.2.ebuild')
-rw-r--r--dev-python/fexpect/fexpect-0.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/fexpect/fexpect-0.2.ebuild b/dev-python/fexpect/fexpect-0.2.ebuild
new file mode 100644
index 000000000000..de6a48b575a2
--- /dev/null
+++ b/dev-python/fexpect/fexpect-0.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Extension for fabric to handle prompts through pexpect"
+HOMEPAGE="https://github.com/ilogue/fexpect"
+SRC_URI="https://github.com/ilogue/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD-2"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/fabric[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/shortuuid[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ esetup.py test
+}