summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/funcparserlib')
-rw-r--r--dev-python/funcparserlib/Manifest5
-rw-r--r--dev-python/funcparserlib/funcparserlib-1.0.0_alpha0-r1.ebuild39
-rw-r--r--dev-python/funcparserlib/funcparserlib-1.0.0_alpha1.ebuild36
-rw-r--r--dev-python/funcparserlib/funcparserlib-1.0.0_alpha2.ebuild31
-rw-r--r--dev-python/funcparserlib/funcparserlib-1.0.1.ebuild (renamed from dev-python/funcparserlib/funcparserlib-1.0.0.ebuild)13
5 files changed, 9 insertions, 115 deletions
diff --git a/dev-python/funcparserlib/Manifest b/dev-python/funcparserlib/Manifest
index c86716cda987..3d28b9a77a2e 100644
--- a/dev-python/funcparserlib/Manifest
+++ b/dev-python/funcparserlib/Manifest
@@ -1,4 +1 @@
-DIST funcparserlib-1.0.0.gh.tar.gz 66709 BLAKE2B 76229795e88b5b880667e41b2cd3d534649893019824e7206f41d188f44e7a67bc1cdb97b0cbcf731eb840ed128f29434d0748d0923a16ea0a3130b3ee10d206 SHA512 431d6b639c46dc84a0a12c8de976cb2c1369f0172a18d1eadbffba31aff12e9cfeded5ebec3ec63065384547000144d65d60003c55e2b23a1a40818d910aaef3
-DIST funcparserlib-1.0.0_alpha0.gh.tar.gz 68260 BLAKE2B e1a9a9a516142d683424df881a7c390a3999438905136fbd394f23856022f14390d22f1dd3914e680d2c188c819cce9cc4f7ff2e485478614dd4632701db4614 SHA512 02cac31d76bb888118a99367811a8cfac28a999ba113ce43f4bd6211cef815ce1793fc1767637dd019728f15d5c408e859d5bc8365a2c53804092f1d6f03e54e
-DIST funcparserlib-1.0.0_alpha1.gh.tar.gz 74033 BLAKE2B bf4ee5011f595c6b7ba7430c63e21243257ddc2e00cccea75bf5b16feca2a629becd28f196d657e024419010051a33e5f12fae29b6f8763b35cb8d1bb9144a6b SHA512 16dbf07edd5cad979c61396adc3ccce7dcedd46b3cf6394ecf35c9fd2b22cdf262bb609ffca9a4b6f9f0c236124a7b7cdd929166d65056ca71e73afa2f6b97e2
-DIST funcparserlib-1.0.0_alpha2.gh.tar.gz 66692 BLAKE2B 5d45b48c0efe6025b50cfd603f2eeac4341b5e41185fbbe1e0b948975ee778fcae05dc229a34bfde28b64f2723c21699ffadd243629244a067951cf17049abb3 SHA512 a7c1f4219bee2b203d5f3a1701e24f838b348965ca5bc090aa8f7af0407344af22ec5eb2e161212e6ece42491a775076f45a36f8e2b691d78a3c639ca4098af1
+DIST funcparserlib-1.0.1.gh.tar.gz 66860 BLAKE2B eb6d70ff37f75bb1452be7b2103a1e756d79231b2d862964e383e4d4317e1ba7de6b744ee8d29f08d81b176d267bf93ceba21e6d47c04bc7f467866d0cd6c8c9 SHA512 d64fe07337822077a0aab6d5049cd81f2ac56ccd9d1db2522c245cadf8cc8421ff1c7931f6a075d821a8634ac8aea51c7ae30fe763e679b70b35955a3f6aa8c7
diff --git a/dev-python/funcparserlib/funcparserlib-1.0.0_alpha0-r1.ebuild b/dev-python/funcparserlib/funcparserlib-1.0.0_alpha0-r1.ebuild
deleted file mode 100644
index eaa5d281e793..000000000000
--- a/dev-python/funcparserlib/funcparserlib-1.0.0_alpha0-r1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-MY_PV="${PV/_alpha/a}"
-
-DESCRIPTION="Recursive descent parsing library based on functional combinators"
-HOMEPAGE="https://pypi.org/project/funcparserlib/"
-SRC_URI="
- https://github.com/vlasovskikh/funcparserlib/archive/${MY_PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv sparc x86"
-
-BDEPEND="test? ( dev-python/six[${PYTHON_USEDEP}] )"
-
-distutils_enable_tests unittest
-
-src_prepare() {
- sed -e '/requires/s:poetry:&-core:' \
- -e '/backend/s:poetry:&.core:' \
- -i pyproject.toml || die
-
- distutils-r1_src_prepare
-}
-
-python_install_all() {
- local DOCS=( doc/*.md )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/funcparserlib/funcparserlib-1.0.0_alpha1.ebuild b/dev-python/funcparserlib/funcparserlib-1.0.0_alpha1.ebuild
deleted file mode 100644
index 61cd5cd72023..000000000000
--- a/dev-python/funcparserlib/funcparserlib-1.0.0_alpha1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-MY_PV="${PV/_alpha/a}"
-
-DESCRIPTION="Recursive descent parsing library based on functional combinators"
-HOMEPAGE="https://pypi.org/project/funcparserlib/"
-SRC_URI="
- https://github.com/vlasovskikh/funcparserlib/archive/${MY_PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-BDEPEND="
- test? (
- dev-python/six[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests unittest
-
-python_install_all() {
- local DOCS=( doc/*.md )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/funcparserlib/funcparserlib-1.0.0_alpha2.ebuild b/dev-python/funcparserlib/funcparserlib-1.0.0_alpha2.ebuild
deleted file mode 100644
index 5688b13e39c9..000000000000
--- a/dev-python/funcparserlib/funcparserlib-1.0.0_alpha2.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-MY_PV="${PV/_alpha/a}"
-
-DESCRIPTION="Recursive descent parsing library based on functional combinators"
-HOMEPAGE="https://pypi.org/project/funcparserlib/"
-SRC_URI="
- https://github.com/vlasovskikh/funcparserlib/archive/${MY_PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-BDEPEND="
- test? (
- dev-python/six[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests unittest
diff --git a/dev-python/funcparserlib/funcparserlib-1.0.0.ebuild b/dev-python/funcparserlib/funcparserlib-1.0.1.ebuild
index 332f7b6a5ad9..8464ebc9f2ce 100644
--- a/dev-python/funcparserlib/funcparserlib-1.0.0.ebuild
+++ b/dev-python/funcparserlib/funcparserlib-1.0.1.ebuild
@@ -1,15 +1,18 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{10..12} )
+
inherit distutils-r1
DESCRIPTION="Recursive descent parsing library based on functional combinators"
-HOMEPAGE="https://pypi.org/project/funcparserlib/
- https://github.com/vlasovskikh/funcparserlib"
+HOMEPAGE="
+ https://github.com/vlasovskikh/funcparserlib/
+ https://pypi.org/project/funcparserlib/
+"
SRC_URI="
https://github.com/vlasovskikh/funcparserlib/archive/${PV}.tar.gz
-> ${P}.gh.tar.gz
@@ -17,7 +20,7 @@ SRC_URI="
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86"
BDEPEND="
test? (