summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/graphcanvas/graphcanvas-4.0.2-r1.ebuild')
-rw-r--r--dev-python/graphcanvas/graphcanvas-4.0.2-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/graphcanvas/graphcanvas-4.0.2-r1.ebuild b/dev-python/graphcanvas/graphcanvas-4.0.2-r1.ebuild
new file mode 100644
index 000000000000..b4759516dee5
--- /dev/null
+++ b/dev-python/graphcanvas/graphcanvas-4.0.2-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Enthought Tool Suite: Interactive Graph (network) Visualization"
+HOMEPAGE="http://pypi.python.org/pypi/graphcanvas"
+SRC_URI="http://www.enthought.com/repo/ets/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+RDEPEND="dev-python/networkx[${PYTHON_USEDEP}]
+ >=dev-python/enable-4[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ docompress -x usr/share/doc/${PF}/examples/
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}