summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/hglib')
-rw-r--r--dev-python/hglib/Manifest2
-rw-r--r--dev-python/hglib/files/hglib-0.3-tests.patch63
-rw-r--r--dev-python/hglib/files/hglib-0.9-pypy-tests.patch86
-rw-r--r--dev-python/hglib/hglib-1.0.ebuild40
-rw-r--r--dev-python/hglib/hglib-1.5.ebuild38
-rw-r--r--dev-python/hglib/metadata.xml16
6 files changed, 245 insertions, 0 deletions
diff --git a/dev-python/hglib/Manifest b/dev-python/hglib/Manifest
new file mode 100644
index 000000000000..bee1d39f0a93
--- /dev/null
+++ b/dev-python/hglib/Manifest
@@ -0,0 +1,2 @@
+DIST python-hglib-1.0.tar.gz 27833 SHA256 766458699a9f2e5f351bfe73164e4f8c30290d10a097aefacd25532f315b3099 SHA512 9c0a61299779aff613131aaabbc255c8648f0fa7ab1806af53f19fbdcece0c8a68ddca7880d25b926d67ff1b9201954b207919fb09f6a290acb078e8bbed7b68 WHIRLPOOL edb5dddcbe7a1f6d94ca76d6f78a2b3a53bd56c15e55ef5810ae32f07d270fd45be8947cb8eadbca3dac2de945e97f63cddd46c90157b688032b79f48b7d29bc
+DIST python-hglib-1.5.tar.gz 27812 SHA256 601c04d8daa806768e3075786ffe9b93ad3574ad2b300107dd615dbe7846a367 SHA512 2506e2ac95488830b90f5f099d231e45833a8f19ce14fc2f3391ae1bf48ca72187b6b57afb633ecbe6cd2c6f3d3f482d75e03ea36406b3a07085ed1b4ef9c6b5 WHIRLPOOL 84e0cdc82344cbe3872f70d9d95ec41da4bb99e3fcece0759dea58d727ca9d650449cba1ef9ca214b954942c801363b7e8fc2fbb1abf6e6a0eb7b8133855c7c1
diff --git a/dev-python/hglib/files/hglib-0.3-tests.patch b/dev-python/hglib/files/hglib-0.3-tests.patch
new file mode 100644
index 000000000000..c75c51013720
--- /dev/null
+++ b/dev-python/hglib/files/hglib-0.3-tests.patch
@@ -0,0 +1,63 @@
+tests require a more generic method to open, close files to work with pypy
+https://bugs.pypy.org/issue1380
+diff -ur python-hglib-0.3.orig/tests/test-import.py python-hglib-0.3/tests/test-import.py
+--- tests/test-import.py 2012-07-01 17:11:01.000000000 +0800
++++ tests/test-import.py 2013-01-23 23:44:12.389473396 +0800
+@@ -22,7 +22,8 @@
+ self.assertEquals(self.client.cat(['a']), '1\n')
+
+ def test_basic_file(self):
+- open('patch', 'wb').write(patch)
++ with open('patch', 'wb') as f:
++ f.write(patch)
+
+ # --no-commit
+ self.client.import_(['patch'], nocommit=True)
+diff -ur python-hglib-0.3.orig/tests/test-config.py python-hglib-0.3/tests/test-config.py
+--- tests/test-config.py 2012-07-01 17:11:01.000000000 +0800
++++ tests/test-config.py 2013-01-23 23:55:06.120502085 +0800
+@@ -3,7 +3,8 @@
+ class test_config(common.basetest):
+ def setUp(self):
+ common.basetest.setUp(self)
+- open('.hg/hgrc', 'a').write('[section]\nkey=value\n')
++ with open('.hg/hgrc', 'a') as f:
++ f.write('[section]\nkey=value\n')
+ self.client = hglib.open()
+
+ def test_basic(self):
+diff -ur python-hglib-0.3.orig/tests/test-paths.py python-hglib-0.3/tests/test-paths.py
+--- tests/test-paths.py 2012-07-01 17:11:01.000000000 +0800
++++ tests/test-paths.py 2013-01-24 00:04:36.266527106 +0800
+@@ -3,8 +3,8 @@
+
+ class test_paths(common.basetest):
+ def test_basic(self):
+- open('.hg/hgrc', 'a').write('[paths]\nfoo = bar\n')
+-
++ with open('.hg/hgrc', 'a') as f:
++ f.write('[paths]\nfoo = bar\n')
+ # hgrc isn't watched for changes yet, have to reopen
+ self.client = hglib.open()
+ paths = self.client.paths()
+diff -ur python-hglib-0.3.orig/tests/test-update.py python-hglib-0.3/tests/test-update.py
+--- tests/test-update.py 2012-11-09 18:56:31.000000000 +0800
++++ tests/test-update.py 2013-01-24 00:05:40.866529942 +0800
+@@ -33,7 +33,8 @@
+ self.client.commit('fourth')
+ self.client.update(rev2)
+ old = open('a').read()
+- open('a', 'wb').write('a' + old)
++ with open('a', 'wb') as f:
++ f.write('a' + old)
+ u, m, r, ur = self.client.update()
+ self.assertEquals(u, 0)
+ self.assertEquals(m, 1)
+@@ -68,5 +69,6 @@
+ self.assertEquals(old, open('a').read())
+
+ def test_basic_plain(self):
+- open('.hg/hgrc', 'a').write('[defaults]\nupdate=-v\n')
++ with open('.hg/hgrc', 'a') as f:
++ f.write('[defaults]\nupdate=-v\n')
+ self.test_basic()
diff --git a/dev-python/hglib/files/hglib-0.9-pypy-tests.patch b/dev-python/hglib/files/hglib-0.9-pypy-tests.patch
new file mode 100644
index 000000000000..1c56f501f495
--- /dev/null
+++ b/dev-python/hglib/files/hglib-0.9-pypy-tests.patch
@@ -0,0 +1,86 @@
+# HG changeset patch
+# User Matt Mackall <mpm@selenic.com>
+# Date 1372027936 18000
+# Node ID e738d6fe5f3ff613a4ee2c0d759eee0ee4f5c9ff
+# Parent 59cb26bf866e793b184842ad23f82fc3551d1742
+tests: make the tests work under Pypy (issue3965)
+
+..which needs explicit close() due to lack of reference counting.
+
+diff -r 59cb26bf866e -r e738d6fe5f3f tests/test-config.py
+--- a/tests/test-config.py Fri Jun 14 18:36:56 2013 +0300
++++ b/tests/test-config.py Sun Jun 23 17:52:16 2013 -0500
+@@ -3,7 +3,9 @@
+ class test_config(common.basetest):
+ def setUp(self):
+ common.basetest.setUp(self)
+- open('.hg/hgrc', 'a').write('[section]\nkey=value\n')
++ f = open('.hg/hgrc', 'a')
++ f.write('[section]\nkey=value\n')
++ f.close()
+ self.client = hglib.open()
+
+ def test_basic(self):
+diff -r 59cb26bf866e -r e738d6fe5f3f tests/test-import.py
+--- a/tests/test-import.py Fri Jun 14 18:36:56 2013 +0300
++++ b/tests/test-import.py Sun Jun 23 17:52:16 2013 -0500
+@@ -22,7 +22,9 @@
+ self.assertEquals(self.client.cat(['a']), '1\n')
+
+ def test_basic_file(self):
+- open('patch', 'wb').write(patch)
++ f = open('patch', 'wb')
++ f.write(patch)
++ f.close()
+
+ # --no-commit
+ self.client.import_(['patch'], nocommit=True)
+diff -r 59cb26bf866e -r e738d6fe5f3f tests/test-paths.py
+--- a/tests/test-paths.py Fri Jun 14 18:36:56 2013 +0300
++++ b/tests/test-paths.py Sun Jun 23 17:52:16 2013 -0500
+@@ -3,7 +3,9 @@
+
+ class test_paths(common.basetest):
+ def test_basic(self):
+- open('.hg/hgrc', 'a').write('[paths]\nfoo = bar\n')
++ f = open('.hg/hgrc', 'a')
++ f.write('[paths]\nfoo = bar\n')
++ f.close()
+
+ # hgrc isn't watched for changes yet, have to reopen
+ self.client = hglib.open()
+diff -r 59cb26bf866e -r e738d6fe5f3f tests/test-update.py
+--- a/tests/test-update.py Fri Jun 14 18:36:56 2013 +0300
++++ b/tests/test-update.py Sun Jun 23 17:52:16 2013 -0500
+@@ -33,7 +33,9 @@
+ self.client.commit('fourth')
+ self.client.update(rev2)
+ old = open('a').read()
+- open('a', 'wb').write('a' + old)
++ f = open('a', 'wb')
++ f.write('a' + old)
++ f.close()
+ u, m, r, ur = self.client.update()
+ self.assertEquals(u, 0)
+ self.assertEquals(m, 1)
+@@ -68,12 +70,16 @@
+ self.assertEquals(old, open('a').read())
+
+ def test_basic_plain(self):
+- open('.hg/hgrc', 'a').write('[defaults]\nupdate=-v\n')
++ f = open('.hg/hgrc', 'a')
++ f.write('[defaults]\nupdate=-v\n')
++ f.close()
+ self.test_basic()
+
+ def test_largefiles(self):
+ import os
+- open('.hg/hgrc', 'a').write('[extensions]\nlargefiles=\n')
++ f = open('.hg/hgrc', 'a')
++ f.write('[extensions]\nlargefiles=\n')
++ f.close()
+ self.append('b', 'a')
+ try:
+ self.client.rawcommand(['add', 'b', '--large'])
+
+
diff --git a/dev-python/hglib/hglib-1.0.ebuild b/dev-python/hglib/hglib-1.0.ebuild
new file mode 100644
index 000000000000..42ab6ed2759f
--- /dev/null
+++ b/dev-python/hglib/hglib-1.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+PYTHON_REQ_USE="threads(+)"
+
+MY_P="python-${P}"
+MY_PN="python-${PN}"
+
+inherit distutils-r1
+
+DESCRIPTION="Library for using the Mercurial Command Server from Python"
+HOMEPAGE="http://mercurial.selenic.com/"
+SRC_URI="mirror://pypi/p/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+RDEPEND=">=dev-vcs/mercurial-2.4.2"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=( "${FILESDIR}"/${PN}-0.3-tests.patch )
+
+python_test() {
+ if ! ${PYTHON} test.py; then
+ die "Tests failed under ${EPYTHON}"
+ fi
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/stats.py )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/hglib/hglib-1.5.ebuild b/dev-python/hglib/hglib-1.5.ebuild
new file mode 100644
index 000000000000..ce56eb7ebc03
--- /dev/null
+++ b/dev-python/hglib/hglib-1.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+PYTHON_REQ_USE="threads(+)"
+
+MY_P="python-${P}"
+MY_PN="python-${PN}"
+
+inherit distutils-r1
+
+DESCRIPTION="Library for using the Mercurial Command Server from Python"
+HOMEPAGE="http://mercurial.selenic.com/"
+SRC_URI="mirror://pypi/p/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+RDEPEND=">=dev-vcs/mercurial-2.4.2"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S=${WORKDIR}/${MY_P}
+
+python_test() {
+ if ! ${PYTHON} test.py; then
+ die "Tests failed under ${EPYTHON}"
+ fi
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/stats.py )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/hglib/metadata.xml b/dev-python/hglib/metadata.xml
new file mode 100644
index 000000000000..22215d7493b9
--- /dev/null
+++ b/dev-python/hglib/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>arne_bab@web.de</email>
+ <name>Arne Babenhauserheide</name>
+ </maintainer>
+ <maintainer>
+ <email>maksbotan@gentoo.org</email>
+ <name>Maxim Koltsov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">python-hglib</remote-id>
+ </upstream>
+</pkgmetadata>